summaryrefslogtreecommitdiffstats
path: root/vendor/clap-3.2.20/examples/cargo-example-derive.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/clap-3.2.20/examples/cargo-example-derive.md
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap-3.2.20/examples/cargo-example-derive.md')
-rw-r--r--vendor/clap-3.2.20/examples/cargo-example-derive.md43
1 files changed, 0 insertions, 43 deletions
diff --git a/vendor/clap-3.2.20/examples/cargo-example-derive.md b/vendor/clap-3.2.20/examples/cargo-example-derive.md
deleted file mode 100644
index 2c7a11b88..000000000
--- a/vendor/clap-3.2.20/examples/cargo-example-derive.md
+++ /dev/null
@@ -1,43 +0,0 @@
-For more on creating a custom subcommand, see [the cargo
-book](https://doc.rust-lang.org/cargo/reference/external-tools.html#custom-subcommands).
-The crate [`clap-cargo`](https://github.com/crate-ci/clap-cargo) can help in
-mimicking cargo's interface.
-
-The help looks like:
-```console
-$ cargo-example-derive --help
-cargo
-
-USAGE:
- cargo <SUBCOMMAND>
-
-OPTIONS:
- -h, --help Print help information
-
-SUBCOMMANDS:
- example-derive A simple to use, efficient, and full-featured Command Line Argument Parser
- help Print this message or the help of the given subcommand(s)
-
-$ cargo-example-derive example-derive --help
-cargo-example-derive [..]
-A simple to use, efficient, and full-featured Command Line Argument Parser
-
-USAGE:
- cargo example-derive [OPTIONS]
-
-OPTIONS:
- -h, --help Print help information
- --manifest-path <MANIFEST_PATH>
- -V, --version Print version information
-
-```
-
-Then to directly invoke the command, run:
-```console
-$ cargo-example-derive example-derive
-None
-
-$ cargo-example-derive example-derive --manifest-path Cargo.toml
-Some("Cargo.toml")
-
-```