summaryrefslogtreecommitdiffstats
path: root/vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs')
-rw-r--r--vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs18
1 files changed, 0 insertions, 18 deletions
diff --git a/vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs b/vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs
deleted file mode 100644
index 8a1722fd3..000000000
--- a/vendor/clap-3.2.20/examples/tutorial_builder/02_crate.rs
+++ /dev/null
@@ -1,18 +0,0 @@
-use clap::{arg, command};
-
-fn main() {
- // requires `cargo` feature, reading name, version, author, and description from `Cargo.toml`
- let matches = command!()
- .arg(arg!(--two <VALUE>))
- .arg(arg!(--one <VALUE>))
- .get_matches();
-
- println!(
- "two: {:?}",
- matches.get_one::<String>("two").expect("required")
- );
- println!(
- "one: {:?}",
- matches.get_one::<String>("one").expect("required")
- );
-}