summaryrefslogtreecommitdiffstats
path: root/vendor/clap-3.2.20/src/_cookbook/mod.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/clap-3.2.20/src/_cookbook/mod.rs
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap-3.2.20/src/_cookbook/mod.rs')
-rw-r--r--vendor/clap-3.2.20/src/_cookbook/mod.rs55
1 files changed, 0 insertions, 55 deletions
diff --git a/vendor/clap-3.2.20/src/_cookbook/mod.rs b/vendor/clap-3.2.20/src/_cookbook/mod.rs
deleted file mode 100644
index 1a78ed11b..000000000
--- a/vendor/clap-3.2.20/src/_cookbook/mod.rs
+++ /dev/null
@@ -1,55 +0,0 @@
-// Contributing
-//
-// New examples:
-// - Building: They must be added to `Cargo.toml` with the appropriate `required-features`.
-// - Testing: Ensure there is a markdown file with [trycmd](https://docs.rs/trycmd) syntax
-// - Link the `.md` file from here
-
-//! # Documentation: Cookbook
-//!
-//! Typed arguments: [derive][typed_derive]
-//! - Topics:
-//! - Custom `parse()`
-//!
-//! Custom cargo command: [builder][cargo_example], [derive][cargo_example_derive]
-//! - Topics:
-//! - Subcommands
-//! - Cargo plugins
-//!
-//! git-like interface: [builder][git], [derive][git_derive]
-//! - Topics:
-//! - Subcommands
-//! - External subcommands
-//! - Optional subcommands
-//! - Default subcommands
-//!
-//! pacman-like interface: [builder][pacman]
-//! - Topics:
-//! - Flag subcommands
-//! - Conflicting arguments
-//!
-//! Escaped positionals with `--`: [builder][escaped_positional], [derive][escaped_positional_derive]
-//!
-//! Multi-call
-//! - busybox: [builder][multicall_busybox]
-//! - Topics:
-//! - Subcommands
-//! - hostname: [builder][multicall_hostname]
-//! - Topics:
-//! - Subcommands
-//!
-//! repl: [builder][repl]
-//! - Topics:
-//! - Read-Eval-Print Loops / Custom command lines
-
-pub mod cargo_example;
-pub mod cargo_example_derive;
-pub mod escaped_positional;
-pub mod escaped_positional_derive;
-pub mod git;
-pub mod git_derive;
-pub mod multicall_busybox;
-pub mod multicall_hostname;
-pub mod pacman;
-pub mod repl;
-pub mod typed_derive;