summaryrefslogtreecommitdiffstats
path: root/vendor/clap-4.3.10/examples/git-derive.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/clap-4.3.10/examples/git-derive.md
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap-4.3.10/examples/git-derive.md')
-rw-r--r--vendor/clap-4.3.10/examples/git-derive.md159
1 files changed, 0 insertions, 159 deletions
diff --git a/vendor/clap-4.3.10/examples/git-derive.md b/vendor/clap-4.3.10/examples/git-derive.md
deleted file mode 100644
index 57edb612e..000000000
--- a/vendor/clap-4.3.10/examples/git-derive.md
+++ /dev/null
@@ -1,159 +0,0 @@
-**This requires enabling the [`derive` feature flag][crate::_features].**
-
-Git is an example of several common subcommand patterns.
-
-Help:
-```console
-$ git-derive
-? failed
-A fictional versioning CLI
-
-Usage: git-derive[EXE] <COMMAND>
-
-Commands:
- clone Clones repos
- diff Compare two commits
- push pushes things
- add adds things
- stash
- help Print this message or the help of the given subcommand(s)
-
-Options:
- -h, --help Print help
-
-$ git-derive help
-A fictional versioning CLI
-
-Usage: git-derive[EXE] <COMMAND>
-
-Commands:
- clone Clones repos
- diff Compare two commits
- push pushes things
- add adds things
- stash
- help Print this message or the help of the given subcommand(s)
-
-Options:
- -h, --help Print help
-
-$ git-derive help add
-adds things
-
-Usage: git-derive[EXE] add <PATH>...
-
-Arguments:
- <PATH>... Stuff to add
-
-Options:
- -h, --help Print help
-
-```
-
-A basic argument:
-```console
-$ git-derive add
-? failed
-adds things
-
-Usage: git-derive[EXE] add <PATH>...
-
-Arguments:
- <PATH>... Stuff to add
-
-Options:
- -h, --help Print help
-
-$ git-derive add Cargo.toml Cargo.lock
-Adding ["Cargo.toml", "Cargo.lock"]
-
-```
-
-Default subcommand:
-```console
-$ git-derive stash -h
-Usage: git-derive[EXE] stash [OPTIONS]
- git-derive[EXE] stash <COMMAND>
-
-Commands:
- push
- pop
- apply
- help Print this message or the help of the given subcommand(s)
-
-Options:
- -m, --message <MESSAGE>
- -h, --help Print help
-
-$ git-derive stash push -h
-Usage: git-derive[EXE] stash push [OPTIONS]
-
-Options:
- -m, --message <MESSAGE>
- -h, --help Print help
-
-$ git-derive stash pop -h
-Usage: git-derive[EXE] stash pop [STASH]
-
-Arguments:
- [STASH]
-
-Options:
- -h, --help Print help
-
-$ git-derive stash -m "Prototype"
-Pushing StashPushArgs { message: Some("Prototype") }
-
-$ git-derive stash pop
-Popping None
-
-$ git-derive stash push -m "Prototype"
-Pushing StashPushArgs { message: Some("Prototype") }
-
-$ git-derive stash pop
-Popping None
-
-```
-
-External subcommands:
-```console
-$ git-derive custom-tool arg1 --foo bar
-Calling out to "custom-tool" with ["arg1", "--foo", "bar"]
-
-```
-
-Last argument:
-```console
-$ git-derive diff --help
-Compare two commits
-
-Usage: git-derive[EXE] diff [OPTIONS] [COMMIT] [COMMIT] [-- <PATH>]
-
-Arguments:
- [COMMIT]
- [COMMIT]
- [PATH]
-
-Options:
- --color[=<WHEN>] [default: auto] [possible values: always, auto, never]
- -h, --help Print help
-
-$ git-derive diff
-Diffing stage..worktree (color=auto)
-
-$ git-derive diff ./src
-Diffing stage..worktree ./src (color=auto)
-
-$ git-derive diff HEAD ./src
-Diffing HEAD..worktree ./src (color=auto)
-
-$ git-derive diff HEAD~~ -- HEAD
-Diffing HEAD~~..worktree HEAD (color=auto)
-
-$ git-derive diff --color
-Diffing stage..worktree (color=always)
-
-$ git-derive diff --color=never
-Diffing stage..worktree (color=never)
-
-```