summaryrefslogtreecommitdiffstats
path: root/vendor/clap_complete/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /vendor/clap_complete/Cargo.toml
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap_complete/Cargo.toml')
-rw-r--r--vendor/clap_complete/Cargo.toml121
1 files changed, 98 insertions, 23 deletions
diff --git a/vendor/clap_complete/Cargo.toml b/vendor/clap_complete/Cargo.toml
index 175767620..060c43c55 100644
--- a/vendor/clap_complete/Cargo.toml
+++ b/vendor/clap_complete/Cargo.toml
@@ -10,70 +10,145 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.60.0"
name = "clap_complete"
-version = "3.1.1"
-include = ["src/**/*", "Cargo.toml", "LICENSE-*", "README.md"]
+version = "4.0.7"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
description = "Generate shell completion scripts for your clap::Command"
-documentation = "https://docs.rs/clap_complete"
readme = "README.md"
-keywords = ["clap", "cli", "completion", "bash"]
+keywords = [
+ "clap",
+ "cli",
+ "completion",
+ "bash",
+]
categories = ["command-line-interface"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/clap-rs/clap/tree/master/clap_complete"
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
-min = 1
-replace = "{{version}}"
search = "Unreleased"
+replace = "{{version}}"
+min = 1
[[package.metadata.release.pre-release-replacements]]
-exactly = 1
file = "CHANGELOG.md"
+search = '\.\.\.HEAD'
replace = "...{{tag_name}}"
-search = "\\.\\.\\.HEAD"
+exactly = 1
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
-min = 1
-replace = "{{date}}"
search = "ReleaseDate"
+replace = "{{date}}"
+min = 1
[[package.metadata.release.pre-release-replacements]]
-exactly = 1
file = "CHANGELOG.md"
-replace = "<!-- next-header -->\n## [Unreleased] - ReleaseDate\n"
search = "<!-- next-header -->"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+exactly = 1
[[package.metadata.release.pre-release-replacements]]
-exactly = 1
file = "CHANGELOG.md"
-replace = "<!-- next-url -->\n[Unreleased]: https://github.com/clap-rs/clap/compare/{{tag_name}}...HEAD"
search = "<!-- next-url -->"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/clap-rs/clap/compare/{{tag_name}}...HEAD"""
+exactly = 1
[[package.metadata.release.pre-release-replacements]]
-exactly = 4
file = "README.md"
-prerelease = true
-replace = "github.com/clap-rs/clap/blob/{{tag_name}}/"
search = "github.com/clap-rs/clap/blob/[^/]+/"
+replace = "github.com/clap-rs/clap/blob/{{tag_name}}/"
+exactly = 4
+prerelease = true
[lib]
bench = false
+
+[[example]]
+name = "dynamic"
+required-features = ["unstable-dynamic"]
+
[dependencies.clap]
-version = "3.1.0"
+version = "4.0.0"
features = ["std"]
default-features = false
+
+[dependencies.clap_lex]
+version = "0.3.0"
+optional = true
+
+[dependencies.is_executable]
+version = "1.0.1"
+optional = true
+
+[dependencies.os_str_bytes]
+version = "6.0"
+features = ["raw_os_str"]
+optional = true
+default-features = false
+
+[dependencies.pathdiff]
+version = "0.2.1"
+optional = true
+
+[dependencies.shlex]
+version = "1.1.0"
+optional = true
+
+[dependencies.unicode-xid]
+version = "0.2.2"
+optional = true
+
[dev-dependencies.clap]
-version = "3.1.0"
-features = ["std", "derive"]
+version = "4.0.0"
+features = [
+ "std",
+ "derive",
+ "help",
+]
default-features = false
-[dev-dependencies.pretty_assertions]
-version = "1.0"
+[dev-dependencies.snapbox]
+version = "0.4"
+features = ["diff"]
+
+[dev-dependencies.trycmd]
+version = "0.14.5"
+features = [
+ "color-auto",
+ "diff",
+ "examples",
+]
+default-features = false
[features]
debug = ["clap/debug"]
default = []
+unstable-dynamic = [
+ "dep:clap_lex",
+ "dep:shlex",
+ "dep:unicode-xid",
+ "dep:os_str_bytes",
+ "clap/derive",
+ "dep:is_executable",
+ "dep:pathdiff",
+]