summaryrefslogtreecommitdiffstats
path: root/vendor/concolor-query
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /vendor/concolor-query
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/concolor-query')
-rw-r--r--vendor/concolor-query/.cargo-checksum.json1
-rw-r--r--vendor/concolor-query/Cargo.lock76
-rw-r--r--vendor/concolor-query/Cargo.toml42
-rw-r--r--vendor/concolor-query/LICENSE-APACHE202
-rw-r--r--vendor/concolor-query/LICENSE-MIT19
-rw-r--r--vendor/concolor-query/README.md15
-rw-r--r--vendor/concolor-query/examples/report.rs19
-rw-r--r--vendor/concolor-query/src/lib.rs134
-rw-r--r--vendor/concolor-query/src/windows.rs61
9 files changed, 569 insertions, 0 deletions
diff --git a/vendor/concolor-query/.cargo-checksum.json b/vendor/concolor-query/.cargo-checksum.json
new file mode 100644
index 000000000..a04937bbe
--- /dev/null
+++ b/vendor/concolor-query/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.lock":"94b28ec915624bda856181977f9ba6f9d965f3e16d25ed3bd879d1491f268676","Cargo.toml":"66871e61b73950f85d96076f96711f549114671382e30202f372e89b0654e458","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"3c3d25d01d6a8e911c4baddc2a0ac74a014928066b7d29f1f7cfa73c2a7550bf","README.md":"127a8c44fd1d47a979b1f7f11708ae44abe8aec81df900aba083ac19330a4aed","examples/report.rs":"29c546f6a9204666f5974f2874e50496d89fac5592c99b981e9afa13d0efd53a","src/lib.rs":"4dd716dbe701acc5644b25d84503d53ea8bc8fb9bf81914b2183526edc63826c","src/windows.rs":"e5a758667da4a5b420c766e62b6b9531ea5c51f570374e335288c8866cffcbd8"},"package":"88d11d52c3d7ca2e6d0040212be9e4dbbcd78b6447f535b6b561f449427944cf"} \ No newline at end of file
diff --git a/vendor/concolor-query/Cargo.lock b/vendor/concolor-query/Cargo.lock
new file mode 100644
index 000000000..4fb295473
--- /dev/null
+++ b/vendor/concolor-query/Cargo.lock
@@ -0,0 +1,76 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+version = 3
+
+[[package]]
+name = "concolor-query"
+version = "0.3.3"
+dependencies = [
+ "windows-sys",
+]
+
+[[package]]
+name = "windows-sys"
+version = "0.45.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "75283be5efb2831d37ea142365f009c02ec203cd29a3ebecbc093d52315b66d0"
+dependencies = [
+ "windows-targets",
+]
+
+[[package]]
+name = "windows-targets"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "8e2522491fbfcd58cc84d47aeb2958948c4b8982e9a2d8a2a35bbaed431390e7"
+dependencies = [
+ "windows_aarch64_gnullvm",
+ "windows_aarch64_msvc",
+ "windows_i686_gnu",
+ "windows_i686_msvc",
+ "windows_x86_64_gnu",
+ "windows_x86_64_gnullvm",
+ "windows_x86_64_msvc",
+]
+
+[[package]]
+name = "windows_aarch64_gnullvm"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "8c9864e83243fdec7fc9c5444389dcbbfd258f745e7853198f365e3c4968a608"
+
+[[package]]
+name = "windows_aarch64_msvc"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "4c8b1b673ffc16c47a9ff48570a9d85e25d265735c503681332589af6253c6c7"
+
+[[package]]
+name = "windows_i686_gnu"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "de3887528ad530ba7bdbb1faa8275ec7a1155a45ffa57c37993960277145d640"
+
+[[package]]
+name = "windows_i686_msvc"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "bf4d1122317eddd6ff351aa852118a2418ad4214e6613a50e0191f7004372605"
+
+[[package]]
+name = "windows_x86_64_gnu"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "c1040f221285e17ebccbc2591ffdc2d44ee1f9186324dd3e84e99ac68d699c45"
+
+[[package]]
+name = "windows_x86_64_gnullvm"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "628bfdf232daa22b0d64fdb62b09fcc36bb01f05a3939e20ab73aaf9470d0463"
+
+[[package]]
+name = "windows_x86_64_msvc"
+version = "0.42.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "447660ad36a13288b1db4d4248e857b510e8c3a225c822ba4fb748c0aafecffd"
diff --git a/vendor/concolor-query/Cargo.toml b/vendor/concolor-query/Cargo.toml
new file mode 100644
index 000000000..a25ce8919
--- /dev/null
+++ b/vendor/concolor-query/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60.0"
+name = "concolor-query"
+version = "0.3.3"
+include = [
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "examples/**/*",
+]
+description = "Look up colored console capabilities"
+readme = "README.md"
+keywords = [
+ "cli",
+ "color",
+ "no-std",
+ "terminal",
+ "ansi",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-cli/concolor"
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.45.0"
+features = [
+ "Win32_System_Console",
+ "Win32_Foundation",
+]
diff --git a/vendor/concolor-query/LICENSE-APACHE b/vendor/concolor-query/LICENSE-APACHE
new file mode 100644
index 000000000..8f71f43fe
--- /dev/null
+++ b/vendor/concolor-query/LICENSE-APACHE
@@ -0,0 +1,202 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
diff --git a/vendor/concolor-query/LICENSE-MIT b/vendor/concolor-query/LICENSE-MIT
new file mode 100644
index 000000000..0182f1272
--- /dev/null
+++ b/vendor/concolor-query/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2019-2021 The typos Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/vendor/concolor-query/README.md b/vendor/concolor-query/README.md
new file mode 100644
index 000000000..caf7b4c56
--- /dev/null
+++ b/vendor/concolor-query/README.md
@@ -0,0 +1,15 @@
+# concolor-query
+
+> **Low level terminal capability lookups**
+
+[![Documentation](https://img.shields.io/badge/docs-master-blue.svg)][Documentation]
+![License](https://img.shields.io/crates/l/concolor-query.svg)
+[![Crates Status](https://img.shields.io/crates/v/concolor-query.svg)](https://crates.io/crates/concolor-query)
+
+## [Contribute](../../CONTRIBUTING.md)
+
+## License
+
+Dual-licensed under [MIT](../../LICENSE-MIT) or [Apache 2.0](../../LICENSE-APACHE)
+
+[Documentation]: https://docs.rs/concolor-query
diff --git a/vendor/concolor-query/examples/report.rs b/vendor/concolor-query/examples/report.rs
new file mode 100644
index 000000000..19ddcb148
--- /dev/null
+++ b/vendor/concolor-query/examples/report.rs
@@ -0,0 +1,19 @@
+fn main() {
+ println!("clicolor: {:?}", concolor_query::clicolor());
+ println!("clicolor_force: {}", concolor_query::clicolor_force());
+ println!("no_color: {}", concolor_query::no_color());
+ println!(
+ "term_supports_ansi_color: {}",
+ concolor_query::term_supports_ansi_color()
+ );
+ println!(
+ "term_supports_color: {}",
+ concolor_query::term_supports_color()
+ );
+ println!("truecolor: {}", concolor_query::truecolor());
+ println!(
+ "enable_ansi_colors: {:?}",
+ concolor_query::windows::enable_ansi_colors()
+ );
+ println!("is_ci: {:?}", concolor_query::is_ci());
+}
diff --git a/vendor/concolor-query/src/lib.rs b/vendor/concolor-query/src/lib.rs
new file mode 100644
index 000000000..4b3745a5f
--- /dev/null
+++ b/vendor/concolor-query/src/lib.rs
@@ -0,0 +1,134 @@
+pub mod windows;
+
+/// Check [CLICOLOR] status
+///
+/// - When `true`, ANSI colors are supported and should be used when the program isn't piped,
+/// similar to [`term_supports_color`]
+/// - When `false`, don’t output ANSI color escape codes, similar to [`no_color`]
+///
+/// See also:
+/// - [terminfo](https://crates.io/crates/terminfo) or [term](https://crates.io/crates/term) for
+/// checking termcaps
+/// - [termbg](https://crates.io/crates/termbg) for detecting background color
+///
+/// [CLICOLOR]: https://bixense.com/clicolors/
+#[inline]
+pub fn clicolor() -> Option<bool> {
+ let value = std::env::var_os("CLICOLOR")?;
+ Some(value != "0")
+}
+
+/// Check [CLICOLOR_FORCE] status
+///
+/// ANSI colors should be enabled no matter what.
+///
+/// [CLICOLOR_FORCE]: https://bixense.com/clicolors/
+#[inline]
+pub fn clicolor_force() -> bool {
+ let value = std::env::var_os("CLICOLOR_FORCE");
+ value
+ .as_deref()
+ .unwrap_or_else(|| std::ffi::OsStr::new("0"))
+ != "0"
+}
+
+/// Check [NO_COLOR] status
+///
+/// When `true`, should prevent the addition of ANSI color.
+///
+/// User-level configuration files and per-instance command-line arguments should override
+/// [NO_COLOR]. A user should be able to export `$NO_COLOR` in their shell configuration file as a
+/// default, but configure a specific program in its configuration file to specifically enable
+/// color.
+///
+/// [NO_COLOR]: https://no-color.org/
+#[inline]
+pub fn no_color() -> bool {
+ let value = std::env::var_os("NO_COLOR");
+ value.as_deref().unwrap_or_else(|| std::ffi::OsStr::new("")) != ""
+}
+
+/// Check `TERM` for color support
+#[inline]
+#[cfg(not(windows))]
+pub fn term_supports_color() -> bool {
+ match std::env::var_os("TERM") {
+ // If TERM isn't set, then we are in a weird environment that
+ // probably doesn't support colors.
+ None => return false,
+ Some(k) => {
+ if k == "dumb" {
+ return false;
+ }
+ }
+ }
+ true
+}
+
+/// Check `TERM` for color support
+#[inline]
+#[cfg(windows)]
+pub fn term_supports_color() -> bool {
+ // On Windows, if TERM isn't set, then we shouldn't automatically
+ // assume that colors aren't allowed. This is unlike Unix environments
+ // where TERM is more rigorously set.
+ if let Some(k) = std::env::var_os("TERM") {
+ if k == "dumb" {
+ return false;
+ }
+ }
+ true
+}
+
+/// Check `TERM` for ANSI color support
+#[inline]
+#[cfg(not(windows))]
+pub fn term_supports_ansi_color() -> bool {
+ term_supports_color()
+}
+
+/// Check `TERM` for ANSI color support
+#[inline]
+#[cfg(windows)]
+pub fn term_supports_ansi_color() -> bool {
+ match std::env::var_os("TERM") {
+ // If TERM isn't set, then we are in a weird environment that
+ // probably doesn't support ansi.
+ None => return false,
+ Some(k) => {
+ // cygwin doesn't seem to support ANSI escape sequences
+ // and instead has its own variety. However, the Windows
+ // console API may be available.
+ if k == "dumb" || k == "cygwin" {
+ return false;
+ }
+ }
+ }
+ true
+}
+
+/// Check [COLORTERM] for truecolor support
+///
+/// [COLORTERM]: https://github.com/termstandard/colors
+#[inline]
+pub fn truecolor() -> bool {
+ let value = std::env::var_os("COLORTERM");
+ let value = value.as_deref().unwrap_or_default();
+ value == "truecolor" || value == "24bit"
+}
+
+/// Report whether this is running in CI
+///
+/// CI is a common environment where, despite being piped, ansi color codes are supported
+///
+/// This is not as exhaustive as you'd find in a crate like `is_ci` but it should work in enough
+/// cases.
+#[inline]
+pub fn is_ci() -> bool {
+ // Assuming its CI based on presence because who would be setting `CI=false`?
+ //
+ // This makes it easier to all of the potential values when considering our known values:
+ // - Gitlab and Github set it to `true`
+ // - Woodpecker sets it to `woodpecker`
+ std::env::var_os("CI").is_some()
+}
diff --git a/vendor/concolor-query/src/windows.rs b/vendor/concolor-query/src/windows.rs
new file mode 100644
index 000000000..ea3e981dd
--- /dev/null
+++ b/vendor/concolor-query/src/windows.rs
@@ -0,0 +1,61 @@
+#[cfg(windows)]
+mod windows_console {
+ use std::os::windows::io::AsRawHandle;
+ use std::os::windows::io::RawHandle;
+
+ use windows_sys::Win32::System::Console::CONSOLE_MODE;
+ use windows_sys::Win32::System::Console::ENABLE_VIRTUAL_TERMINAL_PROCESSING;
+
+ fn enable_vt(handle: RawHandle) -> std::io::Result<()> {
+ unsafe {
+ let handle = std::mem::transmute(handle);
+ if handle == 0 {
+ return Err(std::io::Error::new(
+ std::io::ErrorKind::BrokenPipe,
+ "console is detached",
+ ));
+ }
+
+ let mut dwmode: CONSOLE_MODE = 0;
+ if windows_sys::Win32::System::Console::GetConsoleMode(handle, &mut dwmode) == 0 {
+ return Err(std::io::Error::last_os_error());
+ }
+
+ dwmode |= ENABLE_VIRTUAL_TERMINAL_PROCESSING;
+ if windows_sys::Win32::System::Console::SetConsoleMode(handle, dwmode) == 0 {
+ return Err(std::io::Error::last_os_error());
+ }
+
+ Ok(())
+ }
+ }
+
+ fn enable_ansi_colors_raw() -> std::io::Result<()> {
+ let stdout = std::io::stdout();
+ let stdout_handle = stdout.as_raw_handle();
+ let stderr = std::io::stderr();
+ let stderr_handle = stderr.as_raw_handle();
+
+ enable_vt(stdout_handle)?;
+ if stdout_handle != stderr_handle {
+ enable_vt(stderr_handle)?;
+ }
+
+ Ok(())
+ }
+
+ #[inline]
+ pub fn enable_ansi_colors() -> Option<bool> {
+ Some(enable_ansi_colors_raw().map(|_| true).unwrap_or(false))
+ }
+}
+
+#[cfg(not(windows))]
+mod windows_console {
+ #[inline]
+ pub fn enable_ansi_colors() -> Option<bool> {
+ None
+ }
+}
+
+pub use self::windows_console::enable_ansi_colors;