summaryrefslogtreecommitdiffstats
path: root/vendor/cpufeatures/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/cpufeatures/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cpufeatures/Cargo.toml')
-rw-r--r--vendor/cpufeatures/Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/vendor/cpufeatures/Cargo.toml b/vendor/cpufeatures/Cargo.toml
index f9fea8135..f6b9b715d 100644
--- a/vendor/cpufeatures/Cargo.toml
+++ b/vendor/cpufeatures/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "cpufeatures"
-version = "0.2.5"
+version = "0.2.6"
authors = ["RustCrypto Developers"]
description = """
Lightweight runtime CPU feature detection for x86/x86_64 and aarch64 with
@@ -24,15 +24,18 @@ keywords = [
"cpuid",
"target-feature",
]
-categories = ["no-std"]
+categories = [
+ "hardware-support",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/RustCrypto/utils"
-[target.aarch64-apple-darwin.dependencies.libc]
-version = "0.2.95"
-
[target.aarch64-linux-android.dependencies.libc]
version = "0.2.95"
[target."cfg(all(target_arch = \"aarch64\", target_os = \"linux\"))".dependencies.libc]
version = "0.2.95"
+
+[target."cfg(all(target_arch = \"aarch64\", target_vendor = \"apple\"))".dependencies.libc]
+version = "0.2.95"