summaryrefslogtreecommitdiffstats
path: root/vendor/crypto-bigint/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/crypto-bigint/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/crypto-bigint/Cargo.toml')
-rw-r--r--vendor/crypto-bigint/Cargo.toml23
1 files changed, 17 insertions, 6 deletions
diff --git a/vendor/crypto-bigint/Cargo.toml b/vendor/crypto-bigint/Cargo.toml
index 20d8afd9f..8e9c2b6e5 100644
--- a/vendor/crypto-bigint/Cargo.toml
+++ b/vendor/crypto-bigint/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.57"
+rust-version = "1.65"
name = "crypto-bigint"
-version = "0.4.9"
+version = "0.5.1"
authors = ["RustCrypto Developers"]
description = """
Pure Rust implementation of a big integer library which has been designed from
@@ -46,8 +46,12 @@ rustdoc-args = [
"docsrs",
]
+[[bench]]
+name = "bench"
+harness = false
+
[dependencies.der]
-version = "0.6"
+version = "0.7"
optional = true
default-features = false
@@ -56,7 +60,7 @@ version = "0.14"
optional = true
[dependencies.rand_core]
-version = "0.6"
+version = "0.6.4"
optional = true
[dependencies.rlp]
@@ -65,7 +69,7 @@ optional = true
default-features = false
[dependencies.serdect]
-version = "0.1"
+version = "0.2"
optional = true
default-features = false
@@ -81,12 +85,19 @@ default-features = false
[dev-dependencies.bincode]
version = "1"
+[dev-dependencies.criterion]
+version = "0.4"
+features = ["html_reports"]
+
[dev-dependencies.hex-literal]
version = "0.3"
[dev-dependencies.num-bigint]
version = "0.4"
+[dev-dependencies.num-integer]
+version = "0.1"
+
[dev-dependencies.num-traits]
version = "0.2"
@@ -104,4 +115,4 @@ features = ["std"]
alloc = []
default = ["rand"]
rand = ["rand_core/std"]
-serde = ["serdect"]
+serde = ["dep:serdect"]