summaryrefslogtreecommitdiffstats
path: root/vendor/darling/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/darling/Cargo.toml
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/darling/Cargo.toml')
-rw-r--r--vendor/darling/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/darling/Cargo.toml b/vendor/darling/Cargo.toml
new file mode 100644
index 000000000..865c8ba77
--- /dev/null
+++ b/vendor/darling/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "darling"
+version = "0.20.3"
+authors = ["Ted Driggs <ted.driggs@outlook.com>"]
+exclude = [
+ "/.travis.yml",
+ "/publish.sh",
+ "/.github/**",
+]
+description = """
+A proc-macro library for reading attributes into structs when
+implementing custom derives.
+"""
+documentation = "https://docs.rs/darling/0.20.3"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/TedDriggs/darling"
+
+[dependencies.darling_core]
+version = "=0.20.3"
+
+[dependencies.darling_macro]
+version = "=0.20.3"
+
+[dev-dependencies.proc-macro2]
+version = "1.0.37"
+
+[dev-dependencies.quote]
+version = "1.0.18"
+
+[dev-dependencies.syn]
+version = "2.0.15"
+
+[features]
+default = ["suggestions"]
+diagnostics = ["darling_core/diagnostics"]
+suggestions = ["darling_core/suggestions"]
+
+[target."cfg(compiletests)".dev-dependencies.rustversion]
+version = "1.0.9"
+
+[target."cfg(compiletests)".dev-dependencies.trybuild]
+version = "1.0.38"
+
+[badges.maintenance]
+status = "actively-developed"