summaryrefslogtreecommitdiffstats
path: root/vendor/derivative/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/derivative/Cargo.toml
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/derivative/Cargo.toml')
-rw-r--r--vendor/derivative/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/vendor/derivative/Cargo.toml b/vendor/derivative/Cargo.toml
new file mode 100644
index 000000000..95741fb21
--- /dev/null
+++ b/vendor/derivative/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "derivative"
+version = "2.2.0"
+authors = ["mcarton <cartonmartin+git@gmail.com>"]
+description = "A set of alternative `derive` attributes for Rust"
+documentation = "https://mcarton.github.io/rust-derivative/"
+readme = "README.md"
+keywords = ["derive", "macro", "macro1-1", "plugin"]
+categories = ["rust-patterns"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mcarton/rust-derivative"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0.3"
+features = ["visit", "extra-traits"]
+[dev-dependencies.trybuild]
+version = "1.0.18, <1.0.23"
+
+[features]
+use_core = []