summaryrefslogtreecommitdiffstats
path: root/vendor/dirs-sys-next
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/dirs-sys-next
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/dirs-sys-next')
-rw-r--r--vendor/dirs-sys-next/.cargo-checksum.json1
-rw-r--r--vendor/dirs-sys-next/CHANGELOG.md44
-rw-r--r--vendor/dirs-sys-next/Cargo.toml32
-rw-r--r--vendor/dirs-sys-next/LICENSE-APACHE174
-rw-r--r--vendor/dirs-sys-next/LICENSE-MIT19
-rw-r--r--vendor/dirs-sys-next/README.md65
-rw-r--r--vendor/dirs-sys-next/src/lib.rs198
-rw-r--r--vendor/dirs-sys-next/src/xdg_user_dirs.rs248
8 files changed, 781 insertions, 0 deletions
diff --git a/vendor/dirs-sys-next/.cargo-checksum.json b/vendor/dirs-sys-next/.cargo-checksum.json
new file mode 100644
index 000000000..511774523
--- /dev/null
+++ b/vendor/dirs-sys-next/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"6604e30611fe9cc5f307f622fd4d763c3e0284ee98355830a9d8adfe48b45734","Cargo.toml":"c175070c42d97fe11d1d684b4e47f6a3bcdfef2a1fa6afda44ef42279dbe93ab","LICENSE-APACHE":"d3174ad63e721d4c9dccb8ad4320848992d314369bc46319720b5802c9153fe9","LICENSE-MIT":"6a2e0ade09a7d5f816f11566fee2b151b32235a7fad52b41d49cce96f833c1a9","README.md":"ee16237514c143cd4e1496fb268a5bb1807d102511a54b27ec4c94f477ed9f28","src/lib.rs":"344d57bd4f20ac70ab7ef2cbeb4dc33ce443b8f4fdbddb92e846e4bf25027b62","src/xdg_user_dirs.rs":"a160d7f56fd346febcaa47cea27dc460dc89a0d4c12025673a8a322854bce207"},"package":"4ebda144c4fe02d1f7ea1a7d9641b6fc6b580adcfa024ae48797ecdeb6825b4d"} \ No newline at end of file
diff --git a/vendor/dirs-sys-next/CHANGELOG.md b/vendor/dirs-sys-next/CHANGELOG.md
new file mode 100644
index 000000000..be802b3fd
--- /dev/null
+++ b/vendor/dirs-sys-next/CHANGELOG.md
@@ -0,0 +1,44 @@
+# Changelog
+
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+<!--
+# Guiding Principles
+
+* Changelogs are for _humans_, not machines.
+* There should be an entry for every single version.
+* The same types of changes should be grouped.
+* Versions and sections should be linkable.
+* The latest version comes first.
+* The release date of each version is displayed.
+* Mention whether you follow Semantic Versioning.
+
+# Types of changes
+
+* `Added` for new features.
+* `Changed` for changes in existing functionality.
+* `Deprecated` for soon-to-be removed features.
+* `Removed` for now removed features.
+* `Fixed` for any bug fixes.
+* `Security` in case of vulnerabilities.
+ -->
+
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+
+## [0.1.2] - 2021-01-09
+### Changed
+* Bump `redox_users` by @benesch.
+
+## [0.1.1] - 2020-10-13
+### Changed
+* Use `default-features=false` for `redox_users` crate. This should cut out quite a few
+ unneeded dependencies.
+
+<!-- next-url -->
+[Unreleased]: https://github.com/xdg-rs/dirs/compare/dirs-sys-v0.1.2...HEAD
+[0.1.2]: https://github.com/xdg-rs/dirs/compare/dirs-sys-v0.1.1...dirs-sys-v0.1.2
+[0.1.1]: https://github.com/xdg-rs/dirs/releases/tag/dirs-sys-v0.1.1
diff --git a/vendor/dirs-sys-next/Cargo.toml b/vendor/dirs-sys-next/Cargo.toml
new file mode 100644
index 000000000..e9d8d0ca9
--- /dev/null
+++ b/vendor/dirs-sys-next/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "dirs-sys-next"
+version = "0.1.2"
+authors = ["The @xdg-rs members"]
+include = ["/CHANGELOG.md", "/Cargo.toml", "/LICENSE-*", "/README.md", "/src"]
+description = "system-level helper functions for the dirs and directories crates"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/xdg-rs/dirs/tree/master/dirs-sys"
+[target."cfg(target_os = \"redox\")".dependencies.redox_users]
+version = "0.4.0"
+default-features = false
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]
+[badges.maintenance]
+status = "as-is"
diff --git a/vendor/dirs-sys-next/LICENSE-APACHE b/vendor/dirs-sys-next/LICENSE-APACHE
new file mode 100644
index 000000000..91e18a62b
--- /dev/null
+++ b/vendor/dirs-sys-next/LICENSE-APACHE
@@ -0,0 +1,174 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
diff --git a/vendor/dirs-sys-next/LICENSE-MIT b/vendor/dirs-sys-next/LICENSE-MIT
new file mode 100644
index 000000000..1452dc143
--- /dev/null
+++ b/vendor/dirs-sys-next/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2018-2019 dirs-rs contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/vendor/dirs-sys-next/README.md b/vendor/dirs-sys-next/README.md
new file mode 100644
index 000000000..3c706d80f
--- /dev/null
+++ b/vendor/dirs-sys-next/README.md
@@ -0,0 +1,65 @@
+[![crates.io](https://img.shields.io/crates/v/dirs-sys-next.svg)](https://crates.io/crates/dirs-sys-next)
+[![API documentation](https://docs.rs/dirs-sys-next/badge.svg)](https://docs.rs/dirs-sys-next/)
+
+# `dirs-sys-next`
+
+**NOTE**: This crate is a fork of once-abandoned `dirs-sys` crate.
+
+_Do not use this library directly, use [`dirs-next`] or [`directories-next`]._
+
+## Compatibility
+
+This crate only exists to facilitate code sharing between [`dirs-next`]
+and [`directories-next`].
+
+There are no compatibility guarantees whatsoever.
+Functions may change or disappear without warning or any kind of deprecation period.
+
+## Platforms
+
+This library is written in Rust, and supports Linux, Redox, macOS and Windows.
+Other platforms are also supported; they use the Linux conventions.
+
+## Minimum Rust version policy
+
+The minimal required version of Rust is `1.34.0`^.
+
+We may bump the Rust version in major and minor releases (`x`/`y` in `x.y.z`).
+Changing the Rust version will be written in the CHANGELOG.
+
+^ Except for Redox, where the Rust version depends on the
+[`redox_users`](https://crates.io/crates/redox_users) crate.
+
+## Build
+
+It's possible to cross-compile this library if the necessary toolchains are installed with rustup.
+This is helpful to ensure a change has not broken compilation on a different platform.
+
+The following commands will build this library on Linux, macOS and Windows:
+
+```console
+cargo build --target=x86_64-unknown-linux-gnu
+cargo build --target=x86_64-pc-windows-gnu
+cargo build --target=x86_64-apple-darwin
+cargo build --target=x86_64-unknown-redox
+```
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0
+ ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license
+ ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+## Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.
+
+[`dirs-next`]: https://github.com/xdg-rs/dirs
+[`directories-next`]: https://github.com/xdg-rs/dirs/tree/master/directories
diff --git a/vendor/dirs-sys-next/src/lib.rs b/vendor/dirs-sys-next/src/lib.rs
new file mode 100644
index 000000000..f76862e85
--- /dev/null
+++ b/vendor/dirs-sys-next/src/lib.rs
@@ -0,0 +1,198 @@
+#![warn(rust_2018_idioms)]
+
+use std::ffi::OsString;
+use std::path::PathBuf;
+
+// we don't need to explicitly handle empty strings in the code above,
+// because an empty string is not considered to be a absolute path here.
+pub fn is_absolute_path(path: OsString) -> Option<PathBuf> {
+ let path = PathBuf::from(path);
+ if path.is_absolute() {
+ Some(path)
+ } else {
+ None
+ }
+}
+
+#[cfg(all(unix, not(target_os = "redox")))]
+mod target_unix_not_redox {
+
+ use std::env;
+ use std::ffi::{CStr, OsString};
+ use std::mem;
+ use std::os::unix::ffi::OsStringExt;
+ use std::path::PathBuf;
+ use std::ptr;
+
+ // https://github.com/rust-lang/rust/blob/ef3e3863939217678e5f7e755c4234d224107c64/library/std/src/sys/unix/os.rs#L587
+ pub fn home_dir() -> Option<PathBuf> {
+ return env::var_os("HOME")
+ .and_then(|h| if h.is_empty() { None } else { Some(h) })
+ .or_else(|| unsafe { fallback() })
+ .map(PathBuf::from);
+
+ #[cfg(any(target_os = "android", target_os = "ios", target_os = "emscripten"))]
+ unsafe fn fallback() -> Option<OsString> {
+ None
+ }
+ #[cfg(not(any(target_os = "android", target_os = "ios", target_os = "emscripten")))]
+ unsafe fn fallback() -> Option<OsString> {
+ let amt = match libc::sysconf(libc::_SC_GETPW_R_SIZE_MAX) {
+ n if n < 0 => 512 as usize,
+ n => n as usize,
+ };
+ let mut buf = Vec::with_capacity(amt);
+ let mut passwd: libc::passwd = mem::zeroed();
+ let mut result = ptr::null_mut();
+ match libc::getpwuid_r(libc::getuid(), &mut passwd, buf.as_mut_ptr(), buf.capacity(), &mut result) {
+ 0 if !result.is_null() => {
+ let ptr = passwd.pw_dir as *const _;
+ let bytes = CStr::from_ptr(ptr).to_bytes();
+ if bytes.is_empty() {
+ None
+ } else {
+ Some(OsStringExt::from_vec(bytes.to_vec()))
+ }
+ }
+ _ => None,
+ }
+ }
+ }
+}
+
+#[cfg(all(unix, not(target_os = "redox")))]
+pub use self::target_unix_not_redox::home_dir;
+
+#[cfg(target_os = "redox")]
+mod target_redox {
+
+ use std::path::PathBuf;
+
+ use redox_users::{All, AllUsers, Config};
+
+ pub fn home_dir() -> Option<PathBuf> {
+ let current_uid = redox_users::get_uid().ok()?;
+ let users = AllUsers::basic(Config::default()).ok()?;
+ let user = users.get_by_id(current_uid)?;
+
+ Some(PathBuf::from(user.home.clone()))
+ }
+}
+
+#[cfg(target_os = "redox")]
+pub use self::target_redox::home_dir;
+
+#[cfg(all(unix, not(any(target_os = "macos", target_os = "ios"))))]
+mod xdg_user_dirs;
+
+#[cfg(all(unix, not(any(target_os = "macos", target_os = "ios"))))]
+mod target_unix_not_mac {
+
+ use std::collections::HashMap;
+ use std::env;
+ use std::path::{Path, PathBuf};
+
+ use super::xdg_user_dirs;
+ use super::{home_dir, is_absolute_path};
+
+ fn user_dir_file(home_dir: &Path) -> PathBuf {
+ env::var_os("XDG_CONFIG_HOME")
+ .and_then(is_absolute_path)
+ .unwrap_or_else(|| home_dir.join(".config"))
+ .join("user-dirs.dirs")
+ }
+
+ // this could be optimized further to not create a map and instead retrieve the requested path only
+ pub fn user_dir(user_dir_name: &str) -> Option<PathBuf> {
+ if let Some(home_dir) = home_dir() {
+ xdg_user_dirs::single(&home_dir, &user_dir_file(&home_dir), user_dir_name).remove(user_dir_name)
+ } else {
+ None
+ }
+ }
+
+ pub fn user_dirs(home_dir_path: &Path) -> HashMap<String, PathBuf> {
+ xdg_user_dirs::all(home_dir_path, &user_dir_file(home_dir_path))
+ }
+}
+
+#[cfg(all(unix, not(any(target_os = "macos", target_os = "ios"))))]
+pub use self::target_unix_not_mac::{user_dir, user_dirs};
+
+#[cfg(target_os = "windows")]
+mod target_windows {
+
+ use std::ffi::OsString;
+ use std::os::windows::ffi::OsStringExt;
+ use std::path::PathBuf;
+ use std::ptr;
+ use std::slice;
+
+ use winapi::shared::winerror;
+ use winapi::um::{combaseapi, knownfolders, shlobj, shtypes, winbase, winnt};
+
+ pub fn known_folder(folder_id: shtypes::REFKNOWNFOLDERID) -> Option<PathBuf> {
+ unsafe {
+ let mut path_ptr: winnt::PWSTR = ptr::null_mut();
+ let result = shlobj::SHGetKnownFolderPath(folder_id, 0, ptr::null_mut(), &mut path_ptr);
+ if result == winerror::S_OK {
+ let len = winbase::lstrlenW(path_ptr) as usize;
+ let path = slice::from_raw_parts(path_ptr, len);
+ let ostr: OsString = OsStringExt::from_wide(path);
+ combaseapi::CoTaskMemFree(path_ptr as *mut winapi::ctypes::c_void);
+ Some(PathBuf::from(ostr))
+ } else {
+ None
+ }
+ }
+ }
+
+ pub fn known_folder_profile() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Profile)
+ }
+
+ pub fn known_folder_roaming_app_data() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_RoamingAppData)
+ }
+
+ pub fn known_folder_local_app_data() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_LocalAppData)
+ }
+
+ pub fn known_folder_music() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Music)
+ }
+
+ pub fn known_folder_desktop() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Desktop)
+ }
+
+ pub fn known_folder_documents() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Documents)
+ }
+
+ pub fn known_folder_downloads() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Downloads)
+ }
+
+ pub fn known_folder_pictures() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Pictures)
+ }
+
+ pub fn known_folder_public() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Public)
+ }
+ pub fn known_folder_templates() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Templates)
+ }
+ pub fn known_folder_videos() -> Option<PathBuf> {
+ known_folder(&knownfolders::FOLDERID_Videos)
+ }
+}
+
+#[cfg(target_os = "windows")]
+pub use self::target_windows::{
+ known_folder, known_folder_desktop, known_folder_documents, known_folder_downloads, known_folder_local_app_data,
+ known_folder_music, known_folder_pictures, known_folder_profile, known_folder_public,
+ known_folder_roaming_app_data, known_folder_templates, known_folder_videos,
+};
diff --git a/vendor/dirs-sys-next/src/xdg_user_dirs.rs b/vendor/dirs-sys-next/src/xdg_user_dirs.rs
new file mode 100644
index 000000000..4fabc81d9
--- /dev/null
+++ b/vendor/dirs-sys-next/src/xdg_user_dirs.rs
@@ -0,0 +1,248 @@
+use std::collections::HashMap;
+use std::ffi::OsString;
+use std::fs;
+use std::io::{self, Read};
+use std::os::unix::ffi::OsStringExt;
+use std::path::{Path, PathBuf};
+use std::str;
+
+/// Returns all XDG user directories obtained from $(XDG_CONFIG_HOME)/user-dirs.dirs.
+pub fn all(home_dir_path: &Path, user_dir_file_path: &Path) -> HashMap<String, PathBuf> {
+ let bytes = read_all(user_dir_file_path).unwrap_or_default();
+ parse_user_dirs(home_dir_path, None, &bytes)
+}
+
+/// Returns a single XDG user directory obtained from $(XDG_CONFIG_HOME)/user-dirs.dirs.
+pub fn single(home_dir_path: &Path, user_dir_file_path: &Path, user_dir_name: &str) -> HashMap<String, PathBuf> {
+ let bytes = read_all(user_dir_file_path).unwrap_or_default();
+ parse_user_dirs(home_dir_path, Some(user_dir_name), &bytes)
+}
+
+fn parse_user_dirs(home_dir: &Path, user_dir: Option<&str>, bytes: &[u8]) -> HashMap<String, PathBuf> {
+ let mut user_dirs = HashMap::new();
+
+ for line in bytes.split(|b| *b == b'\n') {
+ let mut single_dir_found = false;
+ let (key, value) = match split_once(line, b'=') {
+ Some(kv) => kv,
+ None => continue,
+ };
+
+ let key = trim_blank(key);
+ let key = if key.starts_with(b"XDG_") && key.ends_with(b"_DIR") {
+ match str::from_utf8(&key[4..key.len() - 4]) {
+ Ok(key) => {
+ if user_dir.is_some() && option_contains(user_dir, key) {
+ single_dir_found = true;
+ key
+ } else if user_dir.is_none() {
+ key
+ } else {
+ continue;
+ }
+ }
+ Err(_) => continue,
+ }
+ } else {
+ continue;
+ };
+
+ // xdg-user-dirs-update uses double quotes and we don't support anything else.
+ let value = trim_blank(value);
+ let mut value =
+ if value.starts_with(b"\"") && value.ends_with(b"\"") { &value[1..value.len() - 1] } else { continue };
+
+ // Path should be either relative to the home directory or absolute.
+ let is_relative = if value == b"$HOME/" {
+ // "Note: To disable a directory, point it to the homedir."
+ // Source: https://www.freedesktop.org/wiki/Software/xdg-user-dirs/
+ // Additionally directory is reassigned to homedir when removed.
+ continue;
+ } else if value.starts_with(b"$HOME/") {
+ value = &value[b"$HOME/".len()..];
+ true
+ } else if value.starts_with(b"/") {
+ false
+ } else {
+ continue;
+ };
+
+ let value = OsString::from_vec(shell_unescape(value));
+
+ let path = if is_relative {
+ let mut path = PathBuf::from(&home_dir);
+ path.push(value);
+ path
+ } else {
+ PathBuf::from(value)
+ };
+
+ user_dirs.insert(key.to_owned(), path);
+ if single_dir_found {
+ break;
+ }
+ }
+
+ user_dirs
+}
+
+/// Reads the entire contents of a file into a byte vector.
+fn read_all(path: &Path) -> io::Result<Vec<u8>> {
+ let mut file = fs::File::open(path)?;
+ let mut bytes = Vec::with_capacity(1024);
+ file.read_to_end(&mut bytes)?;
+ Ok(bytes)
+}
+
+/// Returns bytes before and after first occurrence of separator.
+fn split_once(bytes: &[u8], separator: u8) -> Option<(&[u8], &[u8])> {
+ bytes.iter().position(|b| *b == separator).map(|i| (&bytes[..i], &bytes[i + 1..]))
+}
+
+/// Returns a slice with leading and trailing <blank> characters removed.
+fn trim_blank(bytes: &[u8]) -> &[u8] {
+ // Trim leading <blank> characters.
+ let i = bytes.iter().cloned().take_while(|b| *b == b' ' || *b == b'\t').count();
+ let bytes = &bytes[i..];
+
+ // Trim trailing <blank> characters.
+ let i = bytes.iter().cloned().rev().take_while(|b| *b == b' ' || *b == b'\t').count();
+ &bytes[..bytes.len() - i]
+}
+
+/// Unescape bytes escaped with POSIX shell double-quotes rules (as used by xdg-user-dirs-update).
+fn shell_unescape(escaped: &[u8]) -> Vec<u8> {
+ // We assume that byte string was created by xdg-user-dirs-update which
+ // escapes all characters that might potentially have special meaning,
+ // so there is no need to check if backslash is actually followed by
+ // $ ` " \ or a <newline>.
+
+ let mut unescaped: Vec<u8> = Vec::with_capacity(escaped.len());
+ let mut i = escaped.iter().cloned();
+
+ while let Some(b) = i.next() {
+ if b == b'\\' {
+ if let Some(b) = i.next() {
+ unescaped.push(b);
+ }
+ } else {
+ unescaped.push(b);
+ }
+ }
+
+ unescaped
+}
+
+fn option_contains<T: PartialEq>(option: Option<T>, value: T) -> bool {
+ match option {
+ Some(val) => val == value,
+ None => false,
+ }
+}
+
+#[cfg(test)]
+mod tests {
+ use super::{parse_user_dirs, shell_unescape, split_once, trim_blank};
+ use std::collections::HashMap;
+ use std::path::{Path, PathBuf};
+
+ #[test]
+ fn test_trim_blank() {
+ assert_eq!(b"x", trim_blank(b"x"));
+ assert_eq!(b"", trim_blank(b" \t "));
+ assert_eq!(b"hello there", trim_blank(b" \t hello there \t "));
+ assert_eq!(b"\r\n", trim_blank(b"\r\n"));
+ }
+
+ #[test]
+ fn test_split_once() {
+ assert_eq!(None, split_once(b"a b c", b'='));
+ assert_eq!(Some((b"before".as_ref(), b"after".as_ref())), split_once(b"before=after", b'='));
+ }
+
+ #[test]
+ fn test_shell_unescape() {
+ assert_eq!(b"abc", shell_unescape(b"abc").as_slice());
+ assert_eq!(b"x\\y$z`", shell_unescape(b"x\\\\y\\$z\\`").as_slice());
+ }
+
+ #[test]
+ fn test_parse_empty() {
+ assert_eq!(HashMap::new(), parse_user_dirs(Path::new("/root/"), None, b""));
+ assert_eq!(HashMap::new(), parse_user_dirs(Path::new("/root/"), Some("MUSIC"), b""));
+ }
+
+ #[test]
+ fn test_absolute_path_is_accepted() {
+ let mut dirs = HashMap::new();
+ dirs.insert("MUSIC".to_owned(), PathBuf::from("/media/music"));
+ let bytes = br#"XDG_MUSIC_DIR="/media/music""#;
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), None, bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), Some("MUSIC"), bytes));
+ }
+
+ #[test]
+ fn test_relative_path_is_rejected() {
+ let dirs = HashMap::new();
+ let bytes = br#"XDG_MUSIC_DIR="music""#;
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), None, bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), Some("MUSIC"), bytes));
+ }
+
+ #[test]
+ fn test_relative_to_home() {
+ let mut dirs = HashMap::new();
+ dirs.insert("MUSIC".to_owned(), PathBuf::from("/home/john/Music"));
+ let bytes = br#"XDG_MUSIC_DIR="$HOME/Music""#;
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), None, bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), Some("MUSIC"), bytes));
+ }
+
+ #[test]
+ fn test_disabled_directory() {
+ let dirs = HashMap::new();
+ let bytes = br#"XDG_MUSIC_DIR="$HOME/""#;
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), None, bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/john"), Some("MUSIC"), bytes));
+ }
+
+ #[test]
+ fn test_parse_user_dirs() {
+ let mut dirs: HashMap<String, PathBuf> = HashMap::new();
+ dirs.insert("DESKTOP".to_string(), PathBuf::from("/home/bob/Desktop"));
+ dirs.insert("DOWNLOAD".to_string(), PathBuf::from("/home/bob/Downloads"));
+ dirs.insert("PICTURES".to_string(), PathBuf::from("/home/eve/pics"));
+
+ let bytes = br#"
+# This file is written by xdg-user-dirs-update
+# If you want to change or add directories, just edit the line you're
+# interested in. All local changes will be retained on the next run.
+# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
+# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
+# absolute path. No other format is supported.
+XDG_DESKTOP_DIR="$HOME/Desktop"
+XDG_DOWNLOAD_DIR="$HOME/Downloads"
+XDG_TEMPLATES_DIR=""
+XDG_PUBLICSHARE_DIR="$HOME"
+XDG_DOCUMENTS_DIR="$HOME/"
+XDG_PICTURES_DIR="/home/eve/pics"
+XDG_VIDEOS_DIR="$HOxyzME/Videos"
+"#;
+
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), None, bytes));
+
+ let mut dirs: HashMap<String, PathBuf> = HashMap::new();
+ dirs.insert("DESKTOP".to_string(), PathBuf::from("/home/bob/Desktop"));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("DESKTOP"), bytes));
+
+ let mut dirs: HashMap<String, PathBuf> = HashMap::new();
+ dirs.insert("PICTURES".to_string(), PathBuf::from("/home/eve/pics"));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("PICTURES"), bytes));
+
+ let dirs: HashMap<String, PathBuf> = HashMap::new();
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("TEMPLATES"), bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("PUBLICSHARE"), bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("DOCUMENTS"), bytes));
+ assert_eq!(dirs, parse_user_dirs(Path::new("/home/bob"), Some("VIDEOS"), bytes));
+ }
+}