summaryrefslogtreecommitdiffstats
path: root/vendor/dirs-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/dirs-sys/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/dirs-sys/Cargo.toml')
-rw-r--r--vendor/dirs-sys/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/vendor/dirs-sys/Cargo.toml b/vendor/dirs-sys/Cargo.toml
new file mode 100644
index 000000000..6c4100798
--- /dev/null
+++ b/vendor/dirs-sys/Cargo.toml
@@ -0,0 +1,28 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "dirs-sys"
+version = "0.3.6"
+authors = ["Simon Ochsenreither <simon@ochsenreither.de>"]
+description = "System-level helper functions for the dirs and directories crates."
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dirs-dev/dirs-sys-rs"
+[target."cfg(target_os = \"redox\")".dependencies.redox_users]
+version = "0.4"
+default-features = false
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]