summaryrefslogtreecommitdiffstats
path: root/vendor/dlmalloc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/dlmalloc/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/dlmalloc/Cargo.toml')
-rw-r--r--vendor/dlmalloc/Cargo.toml16
1 files changed, 13 insertions, 3 deletions
diff --git a/vendor/dlmalloc/Cargo.toml b/vendor/dlmalloc/Cargo.toml
index a8caf460d..19d4cae06 100644
--- a/vendor/dlmalloc/Cargo.toml
+++ b/vendor/dlmalloc/Cargo.toml
@@ -11,21 +11,26 @@
[package]
name = "dlmalloc"
-version = "0.2.3"
+version = "0.2.4"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = "A Rust port of the dlmalloc allocator\n"
+description = """
+A Rust port of the dlmalloc allocator
+"""
homepage = "https://github.com/alexcrichton/dlmalloc-rs"
documentation = "https://docs.rs/dlmalloc"
readme = "README.md"
license = "MIT/Apache-2.0"
repository = "https://github.com/alexcrichton/dlmalloc-rs"
+
[package.metadata.docs.rs]
features = ["global"]
+
[profile.release]
debug-assertions = true
[lib]
doctest = false
+
[dependencies.compiler_builtins]
version = "0.1.0"
optional = true
@@ -34,13 +39,18 @@ optional = true
version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
+
[dev-dependencies.rand]
version = "0.3"
[features]
debug = []
global = []
-rustc-dep-of-std = ["core", "compiler_builtins/rustc-dep-of-std"]
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins/rustc-dep-of-std",
+]
+
[target."cfg(all(unix, not(target_arch = \"wasm32\")))".dependencies.libc]
version = "0.2"
default-features = false