summaryrefslogtreecommitdiffstats
path: root/vendor/elasticlunr-rs/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/elasticlunr-rs/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/elasticlunr-rs/Cargo.toml')
-rw-r--r--vendor/elasticlunr-rs/Cargo.toml64
1 files changed, 50 insertions, 14 deletions
diff --git a/vendor/elasticlunr-rs/Cargo.toml b/vendor/elasticlunr-rs/Cargo.toml
index 10e0d8411..ec2f2b56e 100644
--- a/vendor/elasticlunr-rs/Cargo.toml
+++ b/vendor/elasticlunr-rs/Cargo.toml
@@ -3,24 +3,33 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
-rust-version = "1.54"
+rust-version = "1.57.0"
name = "elasticlunr-rs"
-version = "3.0.0"
+version = "3.0.2"
authors = ["Matt Ickstadt <mattico8@gmail.com>"]
-exclude = ["tests/lunr-fixture-gen/**", "js/**"]
+exclude = [
+ "tests/lunr-fixture-gen/",
+ "js/",
+ ".github/",
+]
description = "A partial port of elasticlunr.js to Rust for generating static document search indexes"
documentation = "https://docs.rs/elasticlunr-rs"
readme = "README.md"
-keywords = ["search", "index", "indexing", "lunr", "elasticlunr"]
+keywords = [
+ "search",
+ "index",
+ "indexing",
+ "lunr",
+ "elasticlunr",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/mattico/elasticlunr-rs"
@@ -30,17 +39,18 @@ name = "elasticlunr"
[[bench]]
name = "bench"
harness = false
+
[dependencies.jieba-rs]
version = "0.6"
optional = true
[dependencies.lindera]
-version = "0.13"
+version = "0.14"
features = ["ipadic"]
optional = true
[dependencies.lindera-core]
-version = "0.13"
+version = "0.13.5"
optional = true
[dependencies.regex]
@@ -58,8 +68,9 @@ version = "1.0.34"
[dependencies.serde_json]
version = "1"
+
[dev-dependencies.criterion]
-version = "0.3.0"
+version = "0.4.0"
[dev-dependencies.maplit]
version = "1"
@@ -72,9 +83,33 @@ du = ["rust-stemmers"]
es = ["rust-stemmers"]
fi = ["rust-stemmers"]
fr = ["rust-stemmers"]
+hu = ["rust-stemmers"]
it = ["rust-stemmers"]
-ja = ["lindera", "lindera-core"]
-languages = ["ar", "da", "de", "du", "es", "fi", "fr", "it", "ja", "no", "pt", "ro", "ru", "sv", "tr", "zh"]
+ja = [
+ "lindera",
+ "lindera-core",
+]
+ko = []
+languages = [
+ "ar",
+ "da",
+ "de",
+ "du",
+ "es",
+ "fi",
+ "fr",
+ "hu",
+ "it",
+ "ja",
+ "ko",
+ "no",
+ "pt",
+ "ro",
+ "ru",
+ "sv",
+ "tr",
+ "zh",
+]
no = ["rust-stemmers"]
pt = ["rust-stemmers"]
ro = ["rust-stemmers"]
@@ -82,5 +117,6 @@ ru = ["rust-stemmers"]
sv = ["rust-stemmers"]
tr = ["rust-stemmers"]
zh = ["jieba-rs"]
+
[badges.maintenance]
status = "passively-maintained"