summaryrefslogtreecommitdiffstats
path: root/vendor/errno-0.2.8/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/errno-0.2.8/README.md
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno-0.2.8/README.md')
-rw-r--r--vendor/errno-0.2.8/README.md38
1 files changed, 0 insertions, 38 deletions
diff --git a/vendor/errno-0.2.8/README.md b/vendor/errno-0.2.8/README.md
deleted file mode 100644
index a4762a7d0..000000000
--- a/vendor/errno-0.2.8/README.md
+++ /dev/null
@@ -1,38 +0,0 @@
-# errno [![CI](https://github.com/lambda-fairy/rust-errno/actions/workflows/main.yml/badge.svg)](https://github.com/lambda-fairy/rust-errno/actions/workflows/main.yml) [![Cargo](https://img.shields.io/crates/v/errno.svg)](https://crates.io/crates/errno)
-
-Cross-platform interface to the [`errno`][errno] variable. Works on Rust 1.13 or newer.
-
-Documentation is available at <https://docs.rs/errno>.
-
-[errno]: https://en.wikipedia.org/wiki/Errno.h
-
-
-## Dependency
-
-Add to your `Cargo.toml`:
-
-```toml
-[dependencies]
-errno = "*"
-libc = "*"
-```
-
-
-## Examples
-
-```rust
-extern crate errno;
-use errno::{Errno, errno, set_errno};
-
-// Get the current value of errno
-let e = errno();
-
-// Set the current value of errno
-set_errno(e);
-
-// Extract the error code as an i32
-let code = e.0;
-
-// Display a human-friendly error message
-println!("Error {}: {}", code, e);
-```