summaryrefslogtreecommitdiffstats
path: root/vendor/errno-dragonfly
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/errno-dragonfly
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno-dragonfly')
-rw-r--r--vendor/errno-dragonfly/.cargo-checksum.json1
-rw-r--r--vendor/errno-dragonfly/Cargo.toml27
-rw-r--r--vendor/errno-dragonfly/LICENSE21
-rw-r--r--vendor/errno-dragonfly/README.md3
-rw-r--r--vendor/errno-dragonfly/build.rs3
-rw-r--r--vendor/errno-dragonfly/src/errno.c3
-rw-r--r--vendor/errno-dragonfly/src/lib.rs6
7 files changed, 0 insertions, 64 deletions
diff --git a/vendor/errno-dragonfly/.cargo-checksum.json b/vendor/errno-dragonfly/.cargo-checksum.json
deleted file mode 100644
index 2579ff65f..000000000
--- a/vendor/errno-dragonfly/.cargo-checksum.json
+++ /dev/null
@@ -1 +0,0 @@
-{"files":{"Cargo.toml":"36cf2ca7d85e09d22a7dd384f95c51eb6a7f1a6234d3c54d251dfa575b990430","LICENSE":"e5b1e4fcd8ea2b20b09f378e44ef3f51f4b6a72a72b9f6a729e0f87bddcef97f","README.md":"1e8440a65b6befd65a507b60fb11ab29f314dd77012aa7a11b5d1fadbb5f908f","build.rs":"10d4f05ac56556fea0e98732dc4250ddf3f1acc3fea541c63a0bc130aca772e6","src/errno.c":"a857e47b114acb85fddcb252a610ab5734d225c26b7bedd7c35d7789d46c8526","src/lib.rs":"47245dcfc2d5797584444e70edb1997b2f5e39ecc0779599a7fcded379966c0f"},"package":"aa68f1b12764fab894d2755d2518754e71b4fd80ecfb822714a1206c2aab39bf"} \ No newline at end of file
diff --git a/vendor/errno-dragonfly/Cargo.toml b/vendor/errno-dragonfly/Cargo.toml
deleted file mode 100644
index 51e21437b..000000000
--- a/vendor/errno-dragonfly/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "errno-dragonfly"
-version = "0.1.2"
-authors = ["Michael Neumann <mneumann@ntecs.de>"]
-include = ["Cargo.toml", "LICENSE", "README.md", "build.rs", "src/lib.rs", "src/errno.c"]
-description = "Exposes errno functionality to stable Rust on DragonFlyBSD"
-keywords = ["dragonfly"]
-license = "MIT"
-repository = "https://github.com/mneumann/errno-dragonfly-rs"
-[dependencies.libc]
-version = "0.2"
-default-features = false
-[build-dependencies.cc]
-version = "1.0"
diff --git a/vendor/errno-dragonfly/LICENSE b/vendor/errno-dragonfly/LICENSE
deleted file mode 100644
index 1f1500c81..000000000
--- a/vendor/errno-dragonfly/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2017 Michael Neumann
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/vendor/errno-dragonfly/README.md b/vendor/errno-dragonfly/README.md
deleted file mode 100644
index 9218a7b88..000000000
--- a/vendor/errno-dragonfly/README.md
+++ /dev/null
@@ -1,3 +0,0 @@
-# errno-dragonfly-rs
-
-Exposing `errno` functionality to stable Rust on DragonFly BSD.
diff --git a/vendor/errno-dragonfly/build.rs b/vendor/errno-dragonfly/build.rs
deleted file mode 100644
index b93b9ef87..000000000
--- a/vendor/errno-dragonfly/build.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-fn main() {
- cc::Build::new().file("src/errno.c").compile("liberrno.a");
-}
diff --git a/vendor/errno-dragonfly/src/errno.c b/vendor/errno-dragonfly/src/errno.c
deleted file mode 100644
index 32fb4dab4..000000000
--- a/vendor/errno-dragonfly/src/errno.c
+++ /dev/null
@@ -1,3 +0,0 @@
-#include <errno.h>
-
-int *errno_location() { return &errno; }
diff --git a/vendor/errno-dragonfly/src/lib.rs b/vendor/errno-dragonfly/src/lib.rs
deleted file mode 100644
index 4208344d3..000000000
--- a/vendor/errno-dragonfly/src/lib.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-#![no_std]
-
-#[link(name = "errno", kind = "static")]
-extern "C" {
- pub fn errno_location() -> *mut libc::c_int;
-}