summaryrefslogtreecommitdiffstats
path: root/vendor/errno/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/errno/Cargo.toml
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno/Cargo.toml')
-rw-r--r--vendor/errno/Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/vendor/errno/Cargo.toml b/vendor/errno/Cargo.toml
index bf54b1f46..d35ef19cd 100644
--- a/vendor/errno/Cargo.toml
+++ b/vendor/errno/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.48"
name = "errno"
-version = "0.3.1"
+version = "0.3.5"
authors = ["Chris Wong <lambda.fairy@gmail.com>"]
description = "Cross-platform interface to the `errno` variable."
documentation = "https://docs.rs/errno"
@@ -27,19 +27,19 @@ repository = "https://github.com/lambda-fairy/rust-errno"
[features]
default = ["std"]
-std = []
-
-[target."cfg(target_os=\"dragonfly\")".dependencies.errno-dragonfly]
-version = "0.1.1"
+std = ["libc/std"]
[target."cfg(target_os=\"hermit\")".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(target_os=\"wasi\")".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(unix)".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(windows)".dependencies.windows-sys]
version = "0.48"