summaryrefslogtreecommitdiffstats
path: root/vendor/form_urlencoded/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/form_urlencoded/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/form_urlencoded/Cargo.toml')
-rw-r--r--vendor/form_urlencoded/Cargo.toml14
1 files changed, 12 insertions, 2 deletions
diff --git a/vendor/form_urlencoded/Cargo.toml b/vendor/form_urlencoded/Cargo.toml
index 037361d31..9af785084 100644
--- a/vendor/form_urlencoded/Cargo.toml
+++ b/vendor/form_urlencoded/Cargo.toml
@@ -13,9 +13,10 @@
edition = "2018"
rust-version = "1.51"
name = "form_urlencoded"
-version = "1.1.0"
+version = "1.2.0"
authors = ["The rust-url developers"]
description = "Parser and serializer for the application/x-www-form-urlencoded syntax, as used by HTML forms."
+categories = ["no_std"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/rust-url"
@@ -23,4 +24,13 @@ repository = "https://github.com/servo/rust-url"
test = false
[dependencies.percent-encoding]
-version = "2.2.0"
+version = "2.3.0"
+default-features = false
+
+[features]
+alloc = ["percent-encoding/alloc"]
+default = ["std"]
+std = [
+ "alloc",
+ "percent-encoding/std",
+]