summaryrefslogtreecommitdiffstats
path: root/vendor/git2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/git2/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/git2/Cargo.toml')
-rw-r--r--vendor/git2/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/vendor/git2/Cargo.toml b/vendor/git2/Cargo.toml
new file mode 100644
index 000000000..2f1d10d87
--- /dev/null
+++ b/vendor/git2/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "git2"
+version = "0.17.0"
+authors = [
+ "Josh Triplett <josh@joshtriplett.org>",
+ "Alex Crichton <alex@alexcrichton.com>",
+]
+description = """
+Bindings to libgit2 for interoperating with git repositories. This library is
+both threadsafe and memory safe and allows both reading and writing git
+repositories.
+"""
+documentation = "https://docs.rs/git2"
+readme = "README.md"
+keywords = ["git"]
+categories = ["api-bindings"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/git2-rs"
+
+[dependencies.bitflags]
+version = "1.1.0"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.libgit2-sys]
+version = "0.15.0"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.url]
+version = "2.0"
+
+[dev-dependencies.structopt]
+version = "0.3"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[dev-dependencies.time]
+version = "0.1.39"
+
+[features]
+default = [
+ "ssh",
+ "https",
+ "ssh_key_from_memory",
+]
+https = [
+ "libgit2-sys/https",
+ "openssl-sys",
+ "openssl-probe",
+]
+ssh = ["libgit2-sys/ssh"]
+ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
+unstable = []
+vendored-libgit2 = ["libgit2-sys/vendored"]
+vendored-openssl = [
+ "openssl-sys/vendored",
+ "libgit2-sys/vendored-openssl",
+]
+zlib-ng-compat = ["libgit2-sys/zlib-ng-compat"]
+
+[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
+version = "0.1"
+optional = true
+
+[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
+version = "0.9.0"
+optional = true