summaryrefslogtreecommitdiffstats
path: root/vendor/gix-credentials/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/gix-credentials/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/gix-credentials/Cargo.toml')
-rw-r--r--vendor/gix-credentials/Cargo.toml76
1 files changed, 76 insertions, 0 deletions
diff --git a/vendor/gix-credentials/Cargo.toml b/vendor/gix-credentials/Cargo.toml
new file mode 100644
index 000000000..9612b7859
--- /dev/null
+++ b/vendor/gix-credentials/Cargo.toml
@@ -0,0 +1,76 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-credentials"
+version = "0.11.0"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+description = "A WIP crate of the gitoxide project to interact with git credentials helpers"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+doctest = false
+
+[dependencies.bstr]
+version = "1.3.0"
+features = ["std"]
+default-features = false
+
+[dependencies.document-features]
+version = "0.2.1"
+optional = true
+
+[dependencies.gix-command]
+version = "^0.2.4"
+
+[dependencies.gix-config-value]
+version = "^0.10.1"
+
+[dependencies.gix-path]
+version = "^0.7.2"
+
+[dependencies.gix-prompt]
+version = "^0.3.2"
+
+[dependencies.gix-sec]
+version = "^0.6.2"
+
+[dependencies.gix-url]
+version = "^0.15.0"
+
+[dependencies.serde]
+version = "1.0.114"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.thiserror]
+version = "1.0.32"
+
+[dev-dependencies]
+
+[features]
+serde1 = [
+ "serde",
+ "bstr/serde",
+ "gix-sec/serde1",
+]