summaryrefslogtreecommitdiffstats
path: root/vendor/gix-packetline/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/gix-packetline/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/gix-packetline/Cargo.toml')
-rw-r--r--vendor/gix-packetline/Cargo.toml107
1 files changed, 107 insertions, 0 deletions
diff --git a/vendor/gix-packetline/Cargo.toml b/vendor/gix-packetline/Cargo.toml
new file mode 100644
index 000000000..340690ca9
--- /dev/null
+++ b/vendor/gix-packetline/Cargo.toml
@@ -0,0 +1,107 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-packetline"
+version = "0.14.3"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "CHANGELOG.md",
+]
+description = "A WIP crate of the gitoxide project implementing the pkt-line serialization format"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+features = [
+ "document-features",
+ "blocking-io",
+ "serde1",
+]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+doctest = false
+
+[[test]]
+name = "async-packetline"
+path = "tests/async-packetline.rs"
+required-features = ["async-io"]
+
+[[test]]
+name = "blocking-packetline"
+path = "tests/blocking-packetline.rs"
+required-features = [
+ "blocking-io",
+ "maybe-async/is_sync",
+]
+
+[dependencies.bstr]
+version = "1.3.0"
+features = ["std"]
+default-features = false
+
+[dependencies.document-features]
+version = "0.2.0"
+optional = true
+
+[dependencies.futures-io]
+version = "0.3.16"
+optional = true
+
+[dependencies.futures-lite]
+version = "1.12.0"
+optional = true
+
+[dependencies.hex]
+version = "0.4.2"
+
+[dependencies.pin-project-lite]
+version = "0.2.6"
+optional = true
+
+[dependencies.serde]
+version = "1.0.114"
+features = [
+ "std",
+ "derive",
+]
+optional = true
+default-features = false
+
+[dependencies.thiserror]
+version = "1.0.34"
+
+[dev-dependencies.async-std]
+version = "1.9.0"
+features = ["attributes"]
+
+[dev-dependencies.maybe-async]
+version = "0.2.6"
+
+[features]
+async-io = [
+ "futures-io",
+ "futures-lite",
+ "pin-project-lite",
+]
+blocking-io = []
+default = []
+serde1 = [
+ "serde",
+ "bstr/serde",
+]