summaryrefslogtreecommitdiffstats
path: root/vendor/hashbrown-0.13.2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/hashbrown-0.13.2/Cargo.toml
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/hashbrown-0.13.2/Cargo.toml')
-rw-r--r--vendor/hashbrown-0.13.2/Cargo.toml111
1 files changed, 0 insertions, 111 deletions
diff --git a/vendor/hashbrown-0.13.2/Cargo.toml b/vendor/hashbrown-0.13.2/Cargo.toml
deleted file mode 100644
index c64471533..000000000
--- a/vendor/hashbrown-0.13.2/Cargo.toml
+++ /dev/null
@@ -1,111 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.61.0"
-name = "hashbrown"
-version = "0.13.2"
-authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
-exclude = [
- ".github",
- "/ci/*",
-]
-description = "A Rust port of Google's SwissTable hash map"
-readme = "README.md"
-keywords = [
- "hash",
- "no_std",
- "hashmap",
- "swisstable",
-]
-categories = [
- "data-structures",
- "no-std",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/rust-lang/hashbrown"
-
-[package.metadata.docs.rs]
-features = [
- "nightly",
- "rayon",
- "serde",
- "raw",
-]
-
-[dependencies.ahash]
-version = "0.8.0"
-optional = true
-default-features = false
-
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.bumpalo]
-version = "3.5.0"
-optional = true
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
-[dependencies.rayon]
-version = "1.0"
-optional = true
-
-[dependencies.serde]
-version = "1.0.25"
-optional = true
-default-features = false
-
-[dev-dependencies.doc-comment]
-version = "0.3.1"
-
-[dev-dependencies.fnv]
-version = "1.0.7"
-
-[dev-dependencies.lazy_static]
-version = "1.4"
-
-[dev-dependencies.rand]
-version = "0.8.3"
-features = ["small_rng"]
-
-[dev-dependencies.rayon]
-version = "1.0"
-
-[dev-dependencies.serde_test]
-version = "1.0"
-
-[features]
-default = [
- "ahash",
- "inline-more",
-]
-inline-more = []
-nightly = []
-raw = []
-rustc-dep-of-std = [
- "nightly",
- "core",
- "compiler_builtins",
- "alloc",
- "rustc-internal-api",
-]
-rustc-internal-api = []