summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /vendor/hermit-abi/Cargo.toml
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/hermit-abi/Cargo.toml')
-rw-r--r--vendor/hermit-abi/Cargo.toml20
1 files changed, 3 insertions, 17 deletions
diff --git a/vendor/hermit-abi/Cargo.toml b/vendor/hermit-abi/Cargo.toml
index 314aa6ad4..6ec8e2aa7 100644
--- a/vendor/hermit-abi/Cargo.toml
+++ b/vendor/hermit-abi/Cargo.toml
@@ -12,27 +12,19 @@
[package]
edition = "2021"
name = "hermit-abi"
-version = "0.2.6"
+version = "0.3.1"
authors = ["Stefan Lankes"]
-description = """
-hermit-abi is small interface to call functions from the unikernel RustyHermit.
-It is used to build the target `x86_64-unknown-hermit`.
-"""
-documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
+description = "Hermit system calls definitions."
readme = "README.md"
keywords = [
"unikernel",
"libos",
]
categories = ["os"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/hermitcore/rusty-hermit"
resolver = "1"
-[package.metadata.docs.rs]
-features = ["docs"]
-default-target = "x86_64-unknown-hermit"
-
[dependencies.alloc]
version = "1.0.0"
optional = true
@@ -47,16 +39,10 @@ version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
-[dependencies.libc]
-version = "0.2"
-default-features = false
-
[features]
default = []
-docs = []
rustc-dep-of-std = [
"core",
"alloc",
"compiler_builtins/rustc-dep-of-std",
- "libc/rustc-dep-of-std",
]