summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:50 +0000
commit2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35 (patch)
treed325add32978dbdc1db975a438b3a77d571b1ab8 /vendor/hermit-abi/Cargo.toml
parentReleasing progress-linux version 1.68.2+dfsg1-1~progress7.99u1. (diff)
downloadrustc-2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35.tar.xz
rustc-2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35.zip
Merging upstream version 1.69.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/hermit-abi/Cargo.toml')
-rw-r--r--vendor/hermit-abi/Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/vendor/hermit-abi/Cargo.toml b/vendor/hermit-abi/Cargo.toml
index 6ec8e2aa7..30bb616ed 100644
--- a/vendor/hermit-abi/Cargo.toml
+++ b/vendor/hermit-abi/Cargo.toml
@@ -12,9 +12,13 @@
[package]
edition = "2021"
name = "hermit-abi"
-version = "0.3.1"
+version = "0.3.0"
authors = ["Stefan Lankes"]
-description = "Hermit system calls definitions."
+description = """
+hermit-abi is small interface to call functions from the unikernel RustyHermit.
+It is used to build the target `x86_64-unknown-hermit`.
+"""
+documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
readme = "README.md"
keywords = [
"unikernel",
@@ -25,6 +29,10 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/hermitcore/rusty-hermit"
resolver = "1"
+[package.metadata.docs.rs]
+features = ["docs"]
+default-target = "x86_64-unknown-hermit"
+
[dependencies.alloc]
version = "1.0.0"
optional = true
@@ -41,6 +49,7 @@ package = "rustc-std-workspace-core"
[features]
default = []
+docs = []
rustc-dep-of-std = [
"core",
"alloc",