summaryrefslogtreecommitdiffstats
path: root/vendor/http-auth/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/http-auth/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/http-auth/Cargo.toml')
-rw-r--r--vendor/http-auth/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/vendor/http-auth/Cargo.toml b/vendor/http-auth/Cargo.toml
new file mode 100644
index 000000000..8e7f6e17e
--- /dev/null
+++ b/vendor/http-auth/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "http-auth"
+version = "0.1.6"
+description = "HTTP authentication: parse challenge lists, respond to Basic and Digest challenges. Likely to be extended with server support and additional auth schemes."
+readme = "README.md"
+keywords = ["http", "authentication", "digest", "basic"]
+categories = ["authentication", "parser-implementations", "web-programming::http-client"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/scottlamb/http-auth"
+resolver = "2"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[[example]]
+name = "reqwest"
+required-features = ["http"]
+[dependencies.base64]
+version = "0.13.0"
+optional = true
+
+[dependencies.digest]
+version = "0.10"
+optional = true
+
+[dependencies.hex]
+version = "0.4"
+optional = true
+
+[dependencies.http]
+version = "0.2.5"
+optional = true
+
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[dependencies.md-5]
+version = "0.10"
+optional = true
+
+[dependencies.memchr]
+version = "2.4.1"
+
+[dependencies.rand]
+version = "0.8.4"
+optional = true
+
+[dependencies.sha2]
+version = "0.10"
+optional = true
+[dev-dependencies.pretty_assertions]
+version = "1.0.0"
+
+[dev-dependencies.reqwest]
+version = "0.11.6"
+features = ["blocking"]
+
+[features]
+basic-scheme = ["base64"]
+default = ["basic-scheme", "digest-scheme"]
+digest-scheme = ["digest", "hex", "md-5", "rand", "sha2"]
+trace = ["log"]