summaryrefslogtreecommitdiffstats
path: root/vendor/http-auth/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/http-auth/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/http-auth/Cargo.toml')
-rw-r--r--vendor/http-auth/Cargo.toml39
1 files changed, 32 insertions, 7 deletions
diff --git a/vendor/http-auth/Cargo.toml b/vendor/http-auth/Cargo.toml
index 8e7f6e17e..5d2607f1d 100644
--- a/vendor/http-auth/Cargo.toml
+++ b/vendor/http-auth/Cargo.toml
@@ -11,24 +11,39 @@
[package]
edition = "2018"
+rust-version = "1.57.0"
name = "http-auth"
-version = "0.1.6"
+version = "0.1.8"
description = "HTTP authentication: parse challenge lists, respond to Basic and Digest challenges. Likely to be extended with server support and additional auth schemes."
readme = "README.md"
-keywords = ["http", "authentication", "digest", "basic"]
-categories = ["authentication", "parser-implementations", "web-programming::http-client"]
+keywords = [
+ "http",
+ "authentication",
+ "digest",
+ "basic",
+]
+categories = [
+ "authentication",
+ "parser-implementations",
+ "web-programming::http-client",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/scottlamb/http-auth"
resolver = "2"
+
[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
[[example]]
name = "reqwest"
required-features = ["http"]
+
[dependencies.base64]
-version = "0.13.0"
+version = "0.21.0"
optional = true
[dependencies.digest]
@@ -61,6 +76,7 @@ optional = true
[dependencies.sha2]
version = "0.10"
optional = true
+
[dev-dependencies.pretty_assertions]
version = "1.0.0"
@@ -70,6 +86,15 @@ features = ["blocking"]
[features]
basic-scheme = ["base64"]
-default = ["basic-scheme", "digest-scheme"]
-digest-scheme = ["digest", "hex", "md-5", "rand", "sha2"]
+default = [
+ "basic-scheme",
+ "digest-scheme",
+]
+digest-scheme = [
+ "digest",
+ "hex",
+ "md-5",
+ "rand",
+ "sha2",
+]
trace = ["log"]