summaryrefslogtreecommitdiffstats
path: root/vendor/httpdate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/httpdate
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/httpdate')
-rw-r--r--vendor/httpdate/.cargo-checksum.json1
-rw-r--r--vendor/httpdate/Cargo.toml27
-rw-r--r--vendor/httpdate/LICENSE-APACHE201
-rw-r--r--vendor/httpdate/LICENSE-MIT19
-rw-r--r--vendor/httpdate/README.md27
-rw-r--r--vendor/httpdate/benches/benchmarks.rs57
-rw-r--r--vendor/httpdate/src/date.rs420
-rw-r--r--vendor/httpdate/src/lib.rs160
8 files changed, 912 insertions, 0 deletions
diff --git a/vendor/httpdate/.cargo-checksum.json b/vendor/httpdate/.cargo-checksum.json
new file mode 100644
index 000000000..adaf3eceb
--- /dev/null
+++ b/vendor/httpdate/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"214f35d88fe24ad0bce0c89aa14912a083e7a3bd496cd6c39c915931ee32674f","LICENSE-APACHE":"4d10fe5f3aa176b05b229a248866bad70b834c173f1252a814ff4748d8a13837","LICENSE-MIT":"934887691e05d69d7c86ad3f2c360980fa30c15b035e351f3c9865e99da4debc","README.md":"26318a99a935b392b4fc7527e2376ee67e6b7bb75558882173d25c4408ce9273","benches/benchmarks.rs":"13f1208dfb86e3c02dcd67a4c08c2bae300c0a153de5df437eac4a136579ec23","src/date.rs":"bb1afb1189a9da7f8246f5fd4594d4b29c27bf8da3642fddd9bf54b7ce0b1bd8","src/lib.rs":"83e73452762adf92f4ab476276d6ad72bce9142ffbf730bd0c47549a8dff2699"},"package":"c4a1e36c821dbe04574f602848a19f742f4fb3c98d40449f11bcad18d6b17421"} \ No newline at end of file
diff --git a/vendor/httpdate/Cargo.toml b/vendor/httpdate/Cargo.toml
new file mode 100644
index 000000000..572ff232e
--- /dev/null
+++ b/vendor/httpdate/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "httpdate"
+version = "1.0.2"
+authors = ["Pyfisch <pyfisch@posteo.org>"]
+description = "HTTP date parsing and formatting"
+readme = "README.md"
+keywords = ["http", "date", "time", "simple", "timestamp"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/pyfisch/httpdate"
+
+[[bench]]
+name = "benchmarks"
+harness = false
+[dev-dependencies.criterion]
+version = "0.3.5"
diff --git a/vendor/httpdate/LICENSE-APACHE b/vendor/httpdate/LICENSE-APACHE
new file mode 100644
index 000000000..cd482d897
--- /dev/null
+++ b/vendor/httpdate/LICENSE-APACHE
@@ -0,0 +1,201 @@
+Apache License
+Version 2.0, January 2004
+http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+"License" shall mean the terms and conditions for use, reproduction,
+and distribution as defined by Sections 1 through 9 of this document.
+
+"Licensor" shall mean the copyright owner or entity authorized by
+the copyright owner that is granting the License.
+
+"Legal Entity" shall mean the union of the acting entity and all
+other entities that control, are controlled by, or are under common
+control with that entity. For the purposes of this definition,
+"control" means (i) the power, direct or indirect, to cause the
+direction or management of such entity, whether by contract or
+otherwise, or (ii) ownership of fifty percent (50%) or more of the
+outstanding shares, or (iii) beneficial ownership of such entity.
+
+"You" (or "Your") shall mean an individual or Legal Entity
+exercising permissions granted by this License.
+
+"Source" form shall mean the preferred form for making modifications,
+including but not limited to software source code, documentation
+source, and configuration files.
+
+"Object" form shall mean any form resulting from mechanical
+transformation or translation of a Source form, including but
+not limited to compiled object code, generated documentation,
+and conversions to other media types.
+
+"Work" shall mean the work of authorship, whether in Source or
+Object form, made available under the License, as indicated by a
+copyright notice that is included in or attached to the work
+(an example is provided in the Appendix below).
+
+"Derivative Works" shall mean any work, whether in Source or Object
+form, that is based on (or derived from) the Work and for which the
+editorial revisions, annotations, elaborations, or other modifications
+represent, as a whole, an original work of authorship. For the purposes
+of this License, Derivative Works shall not include works that remain
+separable from, or merely link (or bind by name) to the interfaces of,
+the Work and Derivative Works thereof.
+
+"Contribution" shall mean any work of authorship, including
+the original version of the Work and any modifications or additions
+to that Work or Derivative Works thereof, that is intentionally
+submitted to Licensor for inclusion in the Work by the copyright owner
+or by an individual or Legal Entity authorized to submit on behalf of
+the copyright owner. For the purposes of this definition, "submitted"
+means any form of electronic, verbal, or written communication sent
+to the Licensor or its representatives, including but not limited to
+communication on electronic mailing lists, source code control systems,
+and issue tracking systems that are managed by, or on behalf of, the
+Licensor for the purpose of discussing and improving the Work, but
+excluding communication that is conspicuously marked or otherwise
+designated in writing by the copyright owner as "Not a Contribution."
+
+"Contributor" shall mean Licensor and any individual or Legal Entity
+on behalf of whom a Contribution has been received by Licensor and
+subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+this License, each Contributor hereby grants to You a perpetual,
+worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+copyright license to reproduce, prepare Derivative Works of,
+publicly display, publicly perform, sublicense, and distribute the
+Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+this License, each Contributor hereby grants to You a perpetual,
+worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+(except as stated in this section) patent license to make, have made,
+use, offer to sell, sell, import, and otherwise transfer the Work,
+where such license applies only to those patent claims licensable
+by such Contributor that are necessarily infringed by their
+Contribution(s) alone or by combination of their Contribution(s)
+with the Work to which such Contribution(s) was submitted. If You
+institute patent litigation against any entity (including a
+cross-claim or counterclaim in a lawsuit) alleging that the Work
+or a Contribution incorporated within the Work constitutes direct
+or contributory patent infringement, then any patent licenses
+granted to You under this License for that Work shall terminate
+as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+Work or Derivative Works thereof in any medium, with or without
+modifications, and in Source or Object form, provided that You
+meet the following conditions:
+
+(a) You must give any other recipients of the Work or
+Derivative Works a copy of this License; and
+
+(b) You must cause any modified files to carry prominent notices
+stating that You changed the files; and
+
+(c) You must retain, in the Source form of any Derivative Works
+that You distribute, all copyright, patent, trademark, and
+attribution notices from the Source form of the Work,
+excluding those notices that do not pertain to any part of
+the Derivative Works; and
+
+(d) If the Work includes a "NOTICE" text file as part of its
+distribution, then any Derivative Works that You distribute must
+include a readable copy of the attribution notices contained
+within such NOTICE file, excluding those notices that do not
+pertain to any part of the Derivative Works, in at least one
+of the following places: within a NOTICE text file distributed
+as part of the Derivative Works; within the Source form or
+documentation, if provided along with the Derivative Works; or,
+within a display generated by the Derivative Works, if and
+wherever such third-party notices normally appear. The contents
+of the NOTICE file are for informational purposes only and
+do not modify the License. You may add Your own attribution
+notices within Derivative Works that You distribute, alongside
+or as an addendum to the NOTICE text from the Work, provided
+that such additional attribution notices cannot be construed
+as modifying the License.
+
+You may add Your own copyright statement to Your modifications and
+may provide additional or different license terms and conditions
+for use, reproduction, or distribution of Your modifications, or
+for any such Derivative Works as a whole, provided Your use,
+reproduction, and distribution of the Work otherwise complies with
+the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+any Contribution intentionally submitted for inclusion in the Work
+by You to the Licensor shall be under the terms and conditions of
+this License, without any additional terms or conditions.
+Notwithstanding the above, nothing herein shall supersede or modify
+the terms of any separate license agreement you may have executed
+with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+names, trademarks, service marks, or product names of the Licensor,
+except as required for reasonable and customary use in describing the
+origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+agreed to in writing, Licensor provides the Work (and each
+Contributor provides its Contributions) on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+implied, including, without limitation, any warranties or conditions
+of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+PARTICULAR PURPOSE. You are solely responsible for determining the
+appropriateness of using or redistributing the Work and assume any
+risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+whether in tort (including negligence), contract, or otherwise,
+unless required by applicable law (such as deliberate and grossly
+negligent acts) or agreed to in writing, shall any Contributor be
+liable to You for damages, including any direct, indirect, special,
+incidental, or consequential damages of any character arising as a
+result of this License or out of the use or inability to use the
+Work (including but not limited to damages for loss of goodwill,
+work stoppage, computer failure or malfunction, or any and all
+other commercial damages or losses), even if such Contributor
+has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+the Work or Derivative Works thereof, You may choose to offer,
+and charge a fee for, acceptance of support, warranty, indemnity,
+or other liability obligations and/or rights consistent with this
+License. However, in accepting such obligations, You may act only
+on Your own behalf and on Your sole responsibility, not on behalf
+of any other Contributor, and only if You agree to indemnify,
+defend, and hold each Contributor harmless for any liability
+incurred by, or claims asserted against, such Contributor by reason
+of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+To apply the Apache License to your work, attach the following
+boilerplate notice, with the fields enclosed by brackets "[]"
+replaced with your own identifying information. (Don't include
+the brackets!) The text should be enclosed in the appropriate
+comment syntax for the file format. We also recommend that a
+file or class name and description of purpose be included on the
+same "printed page" as the copyright notice for easier
+identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/httpdate/LICENSE-MIT b/vendor/httpdate/LICENSE-MIT
new file mode 100644
index 000000000..881996415
--- /dev/null
+++ b/vendor/httpdate/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2016 Pyfisch
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/vendor/httpdate/README.md b/vendor/httpdate/README.md
new file mode 100644
index 000000000..c90c6f425
--- /dev/null
+++ b/vendor/httpdate/README.md
@@ -0,0 +1,27 @@
+# Date and time utils for HTTP.
+
+[![Build Status](https://travis-ci.org/pyfisch/httpdate.svg?branch=master)](https://travis-ci.org/pyfisch/httpdate)
+[![Crates.io](https://img.shields.io/crates/v/httpdate.svg)](https://crates.io/crates/httpdate)
+[![Documentation](https://docs.rs/httpdate/badge.svg)](https://docs.rs/httpdate)
+
+Multiple HTTP header fields store timestamps.
+For example a response created on May 15, 2015 may contain the header
+`Date: Fri, 15 May 2015 15:34:21 GMT`. Since the timestamp does not
+contain any timezone or leap second information it is equvivalent to
+writing 1431696861 Unix time. Rust’s `SystemTime` is used to store
+these timestamps.
+
+This crate provides two public functions:
+
+* `parse_http_date` to parse a HTTP datetime string to a system time
+* `fmt_http_date` to format a system time to a IMF-fixdate
+
+In addition it exposes the `HttpDate` type that can be used to parse
+and format timestamps. Convert a sytem time to `HttpDate` and vice versa.
+The `HttpType` (8 bytes) is smaller than `SystemTime` (16 bytes) and
+using the display impl avoids a temporary allocation.
+
+Read the [blog post](https://pyfisch.org/blog/http-datetime-handling/) to learn
+more.
+
+Fuzz it by installing *cargo-fuzz* and running `cargo fuzz run fuzz_target_1`.
diff --git a/vendor/httpdate/benches/benchmarks.rs b/vendor/httpdate/benches/benchmarks.rs
new file mode 100644
index 000000000..4f82467bd
--- /dev/null
+++ b/vendor/httpdate/benches/benchmarks.rs
@@ -0,0 +1,57 @@
+use criterion::{black_box, criterion_group, criterion_main, Criterion};
+
+pub fn parse_imf_fixdate(c: &mut Criterion) {
+ c.bench_function("parse_imf_fixdate", |b| {
+ b.iter(|| {
+ let d = black_box("Sun, 06 Nov 1994 08:49:37 GMT");
+ black_box(httpdate::parse_http_date(d)).unwrap();
+ })
+ });
+}
+
+pub fn parse_rfc850_date(c: &mut Criterion) {
+ c.bench_function("parse_rfc850_date", |b| {
+ b.iter(|| {
+ let d = black_box("Sunday, 06-Nov-94 08:49:37 GMT");
+ black_box(httpdate::parse_http_date(d)).unwrap();
+ })
+ });
+}
+
+pub fn parse_asctime(c: &mut Criterion) {
+ c.bench_function("parse_asctime", |b| {
+ b.iter(|| {
+ let d = black_box("Sun Nov 6 08:49:37 1994");
+ black_box(httpdate::parse_http_date(d)).unwrap();
+ })
+ });
+}
+
+struct BlackBoxWrite;
+
+impl std::fmt::Write for BlackBoxWrite {
+ fn write_str(&mut self, s: &str) -> Result<(), std::fmt::Error> {
+ black_box(s);
+ Ok(())
+ }
+}
+
+pub fn encode_date(c: &mut Criterion) {
+ c.bench_function("encode_date", |b| {
+ let d = "Wed, 21 Oct 2015 07:28:00 GMT";
+ black_box(httpdate::parse_http_date(d)).unwrap();
+ b.iter(|| {
+ use std::fmt::Write;
+ let _ = write!(BlackBoxWrite, "{}", d);
+ })
+ });
+}
+
+criterion_group!(
+ benches,
+ parse_imf_fixdate,
+ parse_rfc850_date,
+ parse_asctime,
+ encode_date
+);
+criterion_main!(benches);
diff --git a/vendor/httpdate/src/date.rs b/vendor/httpdate/src/date.rs
new file mode 100644
index 000000000..9f780b65c
--- /dev/null
+++ b/vendor/httpdate/src/date.rs
@@ -0,0 +1,420 @@
+use std::cmp;
+use std::fmt::{self, Display, Formatter};
+use std::str::FromStr;
+use std::time::{Duration, SystemTime, UNIX_EPOCH};
+
+use crate::Error;
+
+/// HTTP timestamp type.
+///
+/// Parse using `FromStr` impl.
+/// Format using the `Display` trait.
+/// Convert timestamp into/from `SytemTime` to use.
+/// Supports comparsion and sorting.
+#[derive(Copy, Clone, Debug, Eq, PartialEq, Hash)]
+pub struct HttpDate {
+ /// 0...59
+ sec: u8,
+ /// 0...59
+ min: u8,
+ /// 0...23
+ hour: u8,
+ /// 1...31
+ day: u8,
+ /// 1...12
+ mon: u8,
+ /// 1970...9999
+ year: u16,
+ /// 1...7
+ wday: u8,
+}
+
+impl HttpDate {
+ fn is_valid(&self) -> bool {
+ self.sec < 60
+ && self.min < 60
+ && self.hour < 24
+ && self.day > 0
+ && self.day < 32
+ && self.mon > 0
+ && self.mon <= 12
+ && self.year >= 1970
+ && self.year <= 9999
+ && &HttpDate::from(SystemTime::from(*self)) == self
+ }
+}
+
+impl From<SystemTime> for HttpDate {
+ fn from(v: SystemTime) -> HttpDate {
+ let dur = v
+ .duration_since(UNIX_EPOCH)
+ .expect("all times should be after the epoch");
+ let secs_since_epoch = dur.as_secs();
+
+ if secs_since_epoch >= 253402300800 {
+ // year 9999
+ panic!("date must be before year 9999");
+ }
+
+ /* 2000-03-01 (mod 400 year, immediately after feb29 */
+ const LEAPOCH: i64 = 11017;
+ const DAYS_PER_400Y: i64 = 365 * 400 + 97;
+ const DAYS_PER_100Y: i64 = 365 * 100 + 24;
+ const DAYS_PER_4Y: i64 = 365 * 4 + 1;
+
+ let days = (secs_since_epoch / 86400) as i64 - LEAPOCH;
+ let secs_of_day = secs_since_epoch % 86400;
+
+ let mut qc_cycles = days / DAYS_PER_400Y;
+ let mut remdays = days % DAYS_PER_400Y;
+
+ if remdays < 0 {
+ remdays += DAYS_PER_400Y;
+ qc_cycles -= 1;
+ }
+
+ let mut c_cycles = remdays / DAYS_PER_100Y;
+ if c_cycles == 4 {
+ c_cycles -= 1;
+ }
+ remdays -= c_cycles * DAYS_PER_100Y;
+
+ let mut q_cycles = remdays / DAYS_PER_4Y;
+ if q_cycles == 25 {
+ q_cycles -= 1;
+ }
+ remdays -= q_cycles * DAYS_PER_4Y;
+
+ let mut remyears = remdays / 365;
+ if remyears == 4 {
+ remyears -= 1;
+ }
+ remdays -= remyears * 365;
+
+ let mut year = 2000 + remyears + 4 * q_cycles + 100 * c_cycles + 400 * qc_cycles;
+
+ let months = [31, 30, 31, 30, 31, 31, 30, 31, 30, 31, 31, 29];
+ let mut mon = 0;
+ for mon_len in months.iter() {
+ mon += 1;
+ if remdays < *mon_len {
+ break;
+ }
+ remdays -= *mon_len;
+ }
+ let mday = remdays + 1;
+ let mon = if mon + 2 > 12 {
+ year += 1;
+ mon - 10
+ } else {
+ mon + 2
+ };
+
+ let mut wday = (3 + days) % 7;
+ if wday <= 0 {
+ wday += 7
+ };
+
+ HttpDate {
+ sec: (secs_of_day % 60) as u8,
+ min: ((secs_of_day % 3600) / 60) as u8,
+ hour: (secs_of_day / 3600) as u8,
+ day: mday as u8,
+ mon: mon as u8,
+ year: year as u16,
+ wday: wday as u8,
+ }
+ }
+}
+
+impl From<HttpDate> for SystemTime {
+ fn from(v: HttpDate) -> SystemTime {
+ let leap_years =
+ ((v.year - 1) - 1968) / 4 - ((v.year - 1) - 1900) / 100 + ((v.year - 1) - 1600) / 400;
+ let mut ydays = match v.mon {
+ 1 => 0,
+ 2 => 31,
+ 3 => 59,
+ 4 => 90,
+ 5 => 120,
+ 6 => 151,
+ 7 => 181,
+ 8 => 212,
+ 9 => 243,
+ 10 => 273,
+ 11 => 304,
+ 12 => 334,
+ _ => unreachable!(),
+ } + v.day as u64
+ - 1;
+ if is_leap_year(v.year) && v.mon > 2 {
+ ydays += 1;
+ }
+ let days = (v.year as u64 - 1970) * 365 + leap_years as u64 + ydays;
+ UNIX_EPOCH
+ + Duration::from_secs(
+ v.sec as u64 + v.min as u64 * 60 + v.hour as u64 * 3600 + days * 86400,
+ )
+ }
+}
+
+impl FromStr for HttpDate {
+ type Err = Error;
+
+ fn from_str(s: &str) -> Result<HttpDate, Error> {
+ if !s.is_ascii() {
+ return Err(Error(()));
+ }
+ let x = s.trim().as_bytes();
+ let date = parse_imf_fixdate(x)
+ .or_else(|_| parse_rfc850_date(x))
+ .or_else(|_| parse_asctime(x))?;
+ if !date.is_valid() {
+ return Err(Error(()));
+ }
+ Ok(date)
+ }
+}
+
+impl Display for HttpDate {
+ fn fmt(&self, f: &mut Formatter) -> fmt::Result {
+ let wday = match self.wday {
+ 1 => b"Mon",
+ 2 => b"Tue",
+ 3 => b"Wed",
+ 4 => b"Thu",
+ 5 => b"Fri",
+ 6 => b"Sat",
+ 7 => b"Sun",
+ _ => unreachable!(),
+ };
+
+ let mon = match self.mon {
+ 1 => b"Jan",
+ 2 => b"Feb",
+ 3 => b"Mar",
+ 4 => b"Apr",
+ 5 => b"May",
+ 6 => b"Jun",
+ 7 => b"Jul",
+ 8 => b"Aug",
+ 9 => b"Sep",
+ 10 => b"Oct",
+ 11 => b"Nov",
+ 12 => b"Dec",
+ _ => unreachable!(),
+ };
+
+ let mut buf: [u8; 29] = *b" , 00 0000 00:00:00 GMT";
+ buf[0] = wday[0];
+ buf[1] = wday[1];
+ buf[2] = wday[2];
+ buf[5] = b'0' + (self.day / 10) as u8;
+ buf[6] = b'0' + (self.day % 10) as u8;
+ buf[8] = mon[0];
+ buf[9] = mon[1];
+ buf[10] = mon[2];
+ buf[12] = b'0' + (self.year / 1000) as u8;
+ buf[13] = b'0' + (self.year / 100 % 10) as u8;
+ buf[14] = b'0' + (self.year / 10 % 10) as u8;
+ buf[15] = b'0' + (self.year % 10) as u8;
+ buf[17] = b'0' + (self.hour / 10) as u8;
+ buf[18] = b'0' + (self.hour % 10) as u8;
+ buf[20] = b'0' + (self.min / 10) as u8;
+ buf[21] = b'0' + (self.min % 10) as u8;
+ buf[23] = b'0' + (self.sec / 10) as u8;
+ buf[24] = b'0' + (self.sec % 10) as u8;
+ f.write_str(std::str::from_utf8(&buf[..]).unwrap())
+ }
+}
+
+impl Ord for HttpDate {
+ fn cmp(&self, other: &HttpDate) -> cmp::Ordering {
+ SystemTime::from(*self).cmp(&SystemTime::from(*other))
+ }
+}
+
+impl PartialOrd for HttpDate {
+ fn partial_cmp(&self, other: &HttpDate) -> Option<cmp::Ordering> {
+ Some(self.cmp(other))
+ }
+}
+
+fn toint_1(x: u8) -> Result<u8, Error> {
+ let result = x.wrapping_sub(b'0');
+ if result < 10 {
+ Ok(result)
+ } else {
+ Err(Error(()))
+ }
+}
+
+fn toint_2(s: &[u8]) -> Result<u8, Error> {
+ let high = s[0].wrapping_sub(b'0');
+ let low = s[1].wrapping_sub(b'0');
+
+ if high < 10 && low < 10 {
+ Ok(high * 10 + low)
+ } else {
+ Err(Error(()))
+ }
+}
+
+#[allow(clippy::many_single_char_names)]
+fn toint_4(s: &[u8]) -> Result<u16, Error> {
+ let a = u16::from(s[0].wrapping_sub(b'0'));
+ let b = u16::from(s[1].wrapping_sub(b'0'));
+ let c = u16::from(s[2].wrapping_sub(b'0'));
+ let d = u16::from(s[3].wrapping_sub(b'0'));
+
+ if a < 10 && b < 10 && c < 10 && d < 10 {
+ Ok(a * 1000 + b * 100 + c * 10 + d)
+ } else {
+ Err(Error(()))
+ }
+}
+
+fn parse_imf_fixdate(s: &[u8]) -> Result<HttpDate, Error> {
+ // Example: `Sun, 06 Nov 1994 08:49:37 GMT`
+ if s.len() != 29 || &s[25..] != b" GMT" || s[16] != b' ' || s[19] != b':' || s[22] != b':' {
+ return Err(Error(()));
+ }
+ Ok(HttpDate {
+ sec: toint_2(&s[23..25])?,
+ min: toint_2(&s[20..22])?,
+ hour: toint_2(&s[17..19])?,
+ day: toint_2(&s[5..7])?,
+ mon: match &s[7..12] {
+ b" Jan " => 1,
+ b" Feb " => 2,
+ b" Mar " => 3,
+ b" Apr " => 4,
+ b" May " => 5,
+ b" Jun " => 6,
+ b" Jul " => 7,
+ b" Aug " => 8,
+ b" Sep " => 9,
+ b" Oct " => 10,
+ b" Nov " => 11,
+ b" Dec " => 12,
+ _ => return Err(Error(())),
+ },
+ year: toint_4(&s[12..16])?,
+ wday: match &s[..5] {
+ b"Mon, " => 1,
+ b"Tue, " => 2,
+ b"Wed, " => 3,
+ b"Thu, " => 4,
+ b"Fri, " => 5,
+ b"Sat, " => 6,
+ b"Sun, " => 7,
+ _ => return Err(Error(())),
+ },
+ })
+}
+
+fn parse_rfc850_date(s: &[u8]) -> Result<HttpDate, Error> {
+ // Example: `Sunday, 06-Nov-94 08:49:37 GMT`
+ if s.len() < 23 {
+ return Err(Error(()));
+ }
+
+ fn wday<'a>(s: &'a [u8], wday: u8, name: &'static [u8]) -> Option<(u8, &'a [u8])> {
+ if &s[0..name.len()] == name {
+ return Some((wday, &s[name.len()..]));
+ }
+ None
+ }
+ let (wday, s) = wday(s, 1, b"Monday, ")
+ .or_else(|| wday(s, 2, b"Tuesday, "))
+ .or_else(|| wday(s, 3, b"Wednesday, "))
+ .or_else(|| wday(s, 4, b"Thursday, "))
+ .or_else(|| wday(s, 5, b"Friday, "))
+ .or_else(|| wday(s, 6, b"Saturday, "))
+ .or_else(|| wday(s, 7, b"Sunday, "))
+ .ok_or(Error(()))?;
+ if s.len() != 22 || s[12] != b':' || s[15] != b':' || &s[18..22] != b" GMT" {
+ return Err(Error(()));
+ }
+ let mut year = u16::from(toint_2(&s[7..9])?);
+ if year < 70 {
+ year += 2000;
+ } else {
+ year += 1900;
+ }
+ Ok(HttpDate {
+ sec: toint_2(&s[16..18])?,
+ min: toint_2(&s[13..15])?,
+ hour: toint_2(&s[10..12])?,
+ day: toint_2(&s[0..2])?,
+ mon: match &s[2..7] {
+ b"-Jan-" => 1,
+ b"-Feb-" => 2,
+ b"-Mar-" => 3,
+ b"-Apr-" => 4,
+ b"-May-" => 5,
+ b"-Jun-" => 6,
+ b"-Jul-" => 7,
+ b"-Aug-" => 8,
+ b"-Sep-" => 9,
+ b"-Oct-" => 10,
+ b"-Nov-" => 11,
+ b"-Dec-" => 12,
+ _ => return Err(Error(())),
+ },
+ year,
+ wday,
+ })
+}
+
+fn parse_asctime(s: &[u8]) -> Result<HttpDate, Error> {
+ // Example: `Sun Nov 6 08:49:37 1994`
+ if s.len() != 24 || s[10] != b' ' || s[13] != b':' || s[16] != b':' || s[19] != b' ' {
+ return Err(Error(()));
+ }
+ Ok(HttpDate {
+ sec: toint_2(&s[17..19])?,
+ min: toint_2(&s[14..16])?,
+ hour: toint_2(&s[11..13])?,
+ day: {
+ let x = &s[8..10];
+ {
+ if x[0] == b' ' {
+ toint_1(x[1])
+ } else {
+ toint_2(x)
+ }
+ }?
+ },
+ mon: match &s[4..8] {
+ b"Jan " => 1,
+ b"Feb " => 2,
+ b"Mar " => 3,
+ b"Apr " => 4,
+ b"May " => 5,
+ b"Jun " => 6,
+ b"Jul " => 7,
+ b"Aug " => 8,
+ b"Sep " => 9,
+ b"Oct " => 10,
+ b"Nov " => 11,
+ b"Dec " => 12,
+ _ => return Err(Error(())),
+ },
+ year: toint_4(&s[20..24])?,
+ wday: match &s[0..4] {
+ b"Mon " => 1,
+ b"Tue " => 2,
+ b"Wed " => 3,
+ b"Thu " => 4,
+ b"Fri " => 5,
+ b"Sat " => 6,
+ b"Sun " => 7,
+ _ => return Err(Error(())),
+ },
+ })
+}
+
+fn is_leap_year(y: u16) -> bool {
+ y % 4 == 0 && (y % 100 != 0 || y % 400 == 0)
+}
diff --git a/vendor/httpdate/src/lib.rs b/vendor/httpdate/src/lib.rs
new file mode 100644
index 000000000..32603d630
--- /dev/null
+++ b/vendor/httpdate/src/lib.rs
@@ -0,0 +1,160 @@
+//! Date and time utils for HTTP.
+//!
+//! Multiple HTTP header fields store timestamps.
+//! For example a response created on May 15, 2015 may contain the header
+//! `Date: Fri, 15 May 2015 15:34:21 GMT`. Since the timestamp does not
+//! contain any timezone or leap second information it is equvivalent to
+//! writing 1431696861 Unix time. Rust’s `SystemTime` is used to store
+//! these timestamps.
+//!
+//! This crate provides two public functions:
+//!
+//! * `parse_http_date` to parse a HTTP datetime string to a system time
+//! * `fmt_http_date` to format a system time to a IMF-fixdate
+//!
+//! In addition it exposes the `HttpDate` type that can be used to parse
+//! and format timestamps. Convert a sytem time to `HttpDate` and vice versa.
+//! The `HttpType` (8 bytes) is smaller than `SystemTime` (16 bytes) and
+//! using the display impl avoids a temporary allocation.
+#![forbid(unsafe_code)]
+
+use std::error;
+use std::fmt::{self, Display, Formatter};
+use std::io;
+use std::time::SystemTime;
+
+pub use date::HttpDate;
+
+mod date;
+
+/// An opaque error type for all parsing errors.
+#[derive(Debug)]
+pub struct Error(());
+
+impl error::Error for Error {}
+
+impl Display for Error {
+ fn fmt(&self, f: &mut Formatter) -> Result<(), fmt::Error> {
+ f.write_str("string contains no or an invalid date")
+ }
+}
+
+impl From<Error> for io::Error {
+ fn from(e: Error) -> io::Error {
+ io::Error::new(io::ErrorKind::Other, e)
+ }
+}
+
+/// Parse a date from an HTTP header field.
+///
+/// Supports the preferred IMF-fixdate and the legacy RFC 805 and
+/// ascdate formats. Two digit years are mapped to dates between
+/// 1970 and 2069.
+pub fn parse_http_date(s: &str) -> Result<SystemTime, Error> {
+ s.parse::<HttpDate>().map(|d| d.into())
+}
+
+/// Format a date to be used in a HTTP header field.
+///
+/// Dates are formatted as IMF-fixdate: `Fri, 15 May 2015 15:34:21 GMT`.
+pub fn fmt_http_date(d: SystemTime) -> String {
+ format!("{}", HttpDate::from(d))
+}
+
+#[cfg(test)]
+mod tests {
+ use std::str;
+ use std::time::{Duration, UNIX_EPOCH};
+
+ use super::{fmt_http_date, parse_http_date, HttpDate};
+
+ #[test]
+ fn test_rfc_example() {
+ let d = UNIX_EPOCH + Duration::from_secs(784111777);
+ assert_eq!(
+ d,
+ parse_http_date("Sun, 06 Nov 1994 08:49:37 GMT").expect("#1")
+ );
+ assert_eq!(
+ d,
+ parse_http_date("Sunday, 06-Nov-94 08:49:37 GMT").expect("#2")
+ );
+ assert_eq!(d, parse_http_date("Sun Nov 6 08:49:37 1994").expect("#3"));
+ }
+
+ #[test]
+ fn test2() {
+ let d = UNIX_EPOCH + Duration::from_secs(1475419451);
+ assert_eq!(
+ d,
+ parse_http_date("Sun, 02 Oct 2016 14:44:11 GMT").expect("#1")
+ );
+ assert!(parse_http_date("Sun Nov 10 08:00:00 1000").is_err());
+ assert!(parse_http_date("Sun Nov 10 08*00:00 2000").is_err());
+ assert!(parse_http_date("Sunday, 06-Nov-94 08+49:37 GMT").is_err());
+ }
+
+ #[test]
+ fn test3() {
+ let mut d = UNIX_EPOCH;
+ assert_eq!(d, parse_http_date("Thu, 01 Jan 1970 00:00:00 GMT").unwrap());
+ d += Duration::from_secs(3600);
+ assert_eq!(d, parse_http_date("Thu, 01 Jan 1970 01:00:00 GMT").unwrap());
+ d += Duration::from_secs(86400);
+ assert_eq!(d, parse_http_date("Fri, 02 Jan 1970 01:00:00 GMT").unwrap());
+ d += Duration::from_secs(2592000);
+ assert_eq!(d, parse_http_date("Sun, 01 Feb 1970 01:00:00 GMT").unwrap());
+ d += Duration::from_secs(2592000);
+ assert_eq!(d, parse_http_date("Tue, 03 Mar 1970 01:00:00 GMT").unwrap());
+ d += Duration::from_secs(31536005);
+ assert_eq!(d, parse_http_date("Wed, 03 Mar 1971 01:00:05 GMT").unwrap());
+ d += Duration::from_secs(15552000);
+ assert_eq!(d, parse_http_date("Mon, 30 Aug 1971 01:00:05 GMT").unwrap());
+ d += Duration::from_secs(6048000);
+ assert_eq!(d, parse_http_date("Mon, 08 Nov 1971 01:00:05 GMT").unwrap());
+ d += Duration::from_secs(864000000);
+ assert_eq!(d, parse_http_date("Fri, 26 Mar 1999 01:00:05 GMT").unwrap());
+ }
+
+ #[test]
+ fn test_fmt() {
+ let d = UNIX_EPOCH;
+ assert_eq!(fmt_http_date(d), "Thu, 01 Jan 1970 00:00:00 GMT");
+ let d = UNIX_EPOCH + Duration::from_secs(1475419451);
+ assert_eq!(fmt_http_date(d), "Sun, 02 Oct 2016 14:44:11 GMT");
+ }
+
+ #[allow(dead_code)]
+ fn testcase(data: &[u8]) {
+ if let Ok(s) = str::from_utf8(data) {
+ println!("{:?}", s);
+ if let Ok(d) = parse_http_date(s) {
+ let o = fmt_http_date(d);
+ assert!(!o.is_empty());
+ }
+ }
+ }
+
+ #[test]
+ fn size_of() {
+ assert_eq!(::std::mem::size_of::<HttpDate>(), 8);
+ }
+
+ #[test]
+ fn test_date_comparison() {
+ let a = UNIX_EPOCH + Duration::from_secs(784111777);
+ let b = a + Duration::from_secs(30);
+ assert!(a < b);
+ let a_date: HttpDate = a.into();
+ let b_date: HttpDate = b.into();
+ assert!(a_date < b_date);
+ assert_eq!(a_date.cmp(&b_date), ::std::cmp::Ordering::Less)
+ }
+
+ #[test]
+ fn test_parse_bad_date() {
+ // 1994-11-07 is actually a Monday
+ let parsed = "Sun, 07 Nov 1994 08:48:37 GMT".parse::<HttpDate>();
+ assert!(parsed.is_err())
+ }
+}