summaryrefslogtreecommitdiffstats
path: root/vendor/icu_list/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/icu_list/Cargo.toml
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/icu_list/Cargo.toml')
-rw-r--r--vendor/icu_list/Cargo.toml114
1 files changed, 114 insertions, 0 deletions
diff --git a/vendor/icu_list/Cargo.toml b/vendor/icu_list/Cargo.toml
new file mode 100644
index 000000000..805f2aea4
--- /dev/null
+++ b/vendor/icu_list/Cargo.toml
@@ -0,0 +1,114 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "icu_list"
+version = "1.0.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "ECMA-402 ListFormatter"
+readme = "README.md"
+categories = ["internationalization"]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[lib]
+path = "src/lib.rs"
+
+[[example]]
+name = "and_list"
+
+[dependencies.databake]
+version = "0.1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.deduplicating_array]
+version = "0.1"
+optional = true
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.icu_locid]
+version = "1.0.0"
+
+[dependencies.icu_provider]
+version = "1.0.0"
+features = ["macros"]
+
+[dependencies.regex-automata]
+version = "0.2"
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.writeable]
+version = "0.5"
+
+[dependencies.zerovec]
+version = "0.9"
+features = ["yoke"]
+
+[dev-dependencies.criterion]
+version = "0.3.3"
+
+[dev-dependencies.icu_benchmark_macros]
+version = "0.7"
+
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["use-std"]
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[features]
+bench = []
+datagen = [
+ "serde",
+ "std",
+ "databake",
+]
+serde = [
+ "dep:serde",
+ "icu_provider/serde",
+ "zerovec/serde",
+ "deduplicating_array",
+]
+serde_human = [
+ "serde",
+ "regex-automata/alloc",
+]
+std = [
+ "icu_provider/std",
+ "icu_locid/std",
+ "regex-automata/std",
+ "regex-automata/alloc",
+]