summaryrefslogtreecommitdiffstats
path: root/vendor/idna/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/idna/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/idna/Cargo.toml')
-rw-r--r--vendor/idna/Cargo.toml19
1 files changed, 16 insertions, 3 deletions
diff --git a/vendor/idna/Cargo.toml b/vendor/idna/Cargo.toml
index fa2ed42bc..373951542 100644
--- a/vendor/idna/Cargo.toml
+++ b/vendor/idna/Cargo.toml
@@ -13,10 +13,11 @@
edition = "2018"
rust-version = "1.51"
name = "idna"
-version = "0.3.0"
+version = "0.4.0"
authors = ["The rust-url developers"]
autotests = false
description = "IDNA (Internationalizing Domain Names in Applications) and Punycode."
+categories = ["no_std"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/rust-url/"
@@ -35,10 +36,13 @@ name = "all"
harness = false
[dependencies.unicode-bidi]
-version = "0.3"
+version = "0.3.10"
+features = ["hardcoded-data"]
+default-features = false
[dependencies.unicode-normalization]
-version = "0.1.17"
+version = "0.1.22"
+default-features = false
[dev-dependencies.assert_matches]
version = "1.3"
@@ -51,3 +55,12 @@ version = "1.0"
[dev-dependencies.tester]
version = "0.9"
+
+[features]
+alloc = []
+default = ["std"]
+std = [
+ "alloc",
+ "unicode-bidi/std",
+ "unicode-normalization/std",
+]