summaryrefslogtreecommitdiffstats
path: root/vendor/intl_pluralrules/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/intl_pluralrules/Cargo.toml
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/intl_pluralrules/Cargo.toml')
-rw-r--r--vendor/intl_pluralrules/Cargo.toml40
1 files changed, 28 insertions, 12 deletions
diff --git a/vendor/intl_pluralrules/Cargo.toml b/vendor/intl_pluralrules/Cargo.toml
index 0dc0a943d..b5db6e609 100644
--- a/vendor/intl_pluralrules/Cargo.toml
+++ b/vendor/intl_pluralrules/Cargo.toml
@@ -3,40 +3,56 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "intl_pluralrules"
-version = "7.0.1"
-authors = ["Kekoa Riggin <kekoariggin@gmail.com>", "Zibi Braniecki <zbraniecki@mozilla.com>"]
-include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+version = "7.0.2"
+authors = [
+ "Kekoa Riggin <kekoariggin@gmail.com>",
+ "Zibi Braniecki <zbraniecki@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "benches/*.rs",
+ "Cargo.toml",
+ "README.md",
+]
description = "Unicode Plural Rules categorizer for numeric input."
readme = "README.md"
-keywords = ["localization", "l10n", "i18n", "intl", "internationalization"]
-categories = ["localization", "internationalization"]
+keywords = [
+ "localization",
+ "l10n",
+ "i18n",
+ "intl",
+ "internationalization",
+]
+categories = [
+ "localization",
+ "internationalization",
+]
license = "Apache-2.0/MIT"
repository = "https://github.com/zbraniecki/pluralrules"
[[bench]]
name = "pluralrules"
harness = false
-[dependencies.tinystr]
-version = "0.3.2"
[dependencies.unic-langid]
version = "0.9"
+
[dev-dependencies.criterion]
version = "0.3"
[dev-dependencies.unic-langid]
version = "0.9"
features = ["macros"]
+
[badges.coveralls]
branch = "master"
repository = "zbraniecki/pluralrules"