summaryrefslogtreecommitdiffstats
path: root/vendor/itoa
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/itoa
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/itoa')
-rw-r--r--vendor/itoa/.cargo-checksum.json1
-rw-r--r--vendor/itoa/Cargo.toml30
-rw-r--r--vendor/itoa/LICENSE-APACHE201
-rw-r--r--vendor/itoa/LICENSE-MIT23
-rw-r--r--vendor/itoa/README.md59
-rw-r--r--vendor/itoa/benches/bench.rs55
-rw-r--r--vendor/itoa/src/lib.rs284
-rw-r--r--vendor/itoa/src/udiv128.rs43
-rw-r--r--vendor/itoa/tests/test.rs29
9 files changed, 725 insertions, 0 deletions
diff --git a/vendor/itoa/.cargo-checksum.json b/vendor/itoa/.cargo-checksum.json
new file mode 100644
index 000000000..3422ca4a1
--- /dev/null
+++ b/vendor/itoa/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"3c81fd59c059ee454f7812e8a9e90078880a4c101964ac4ce63537cec7d36c1e","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"8e9d4e6ac0c740793958bf57c3dbd62827340cf77a282633c388aff70a7c1a22","benches/bench.rs":"636f3093bd461210ad3063289d455f90669c4a1be3273bcd30898de39f02c641","src/lib.rs":"f3b4bd0934f41b8f8a8828a22a9f5ad2af1ac1e7b632743ec2de46fbb4cb0b59","src/udiv128.rs":"16394f767854452756372d74f8025f7329fd8b61a676d81edf489681a6332ee9","tests/test.rs":"f7404fc5f7cd1bdaf74a3b64a70d5b30586241ddc1ce2c82bd1b564999fcce0e"},"package":"112c678d4050afce233f4f2852bb2eb519230b3cf12f33585275537d7e41578d"} \ No newline at end of file
diff --git a/vendor/itoa/Cargo.toml b/vendor/itoa/Cargo.toml
new file mode 100644
index 000000000..51506e7a1
--- /dev/null
+++ b/vendor/itoa/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "itoa"
+version = "1.0.2"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+exclude = [
+ "performance.png",
+ "chart/**",
+]
+description = "Fast integer primitive to string conversion"
+documentation = "https://docs.rs/itoa"
+readme = "README.md"
+categories = ["value-formatting"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/itoa"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
diff --git a/vendor/itoa/LICENSE-APACHE b/vendor/itoa/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/itoa/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/itoa/LICENSE-MIT b/vendor/itoa/LICENSE-MIT
new file mode 100644
index 000000000..31aa79387
--- /dev/null
+++ b/vendor/itoa/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/itoa/README.md b/vendor/itoa/README.md
new file mode 100644
index 000000000..6e241e1c3
--- /dev/null
+++ b/vendor/itoa/README.md
@@ -0,0 +1,59 @@
+itoa
+====
+
+[<img alt="github" src="https://img.shields.io/badge/github-dtolnay/itoa-8da0cb?style=for-the-badge&labelColor=555555&logo=github" height="20">](https://github.com/dtolnay/itoa)
+[<img alt="crates.io" src="https://img.shields.io/crates/v/itoa.svg?style=for-the-badge&color=fc8d62&logo=rust" height="20">](https://crates.io/crates/itoa)
+[<img alt="docs.rs" src="https://img.shields.io/badge/docs.rs-itoa-66c2a5?style=for-the-badge&labelColor=555555&logoColor=white&logo=data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDUxMiA1MTIiPjxwYXRoIGZpbGw9IiNmNWY1ZjUiIGQ9Ik00ODguNiAyNTAuMkwzOTIgMjE0VjEwNS41YzAtMTUtOS4zLTI4LjQtMjMuNC0zMy43bC0xMDAtMzcuNWMtOC4xLTMuMS0xNy4xLTMuMS0yNS4zIDBsLTEwMCAzNy41Yy0xNC4xIDUuMy0yMy40IDE4LjctMjMuNCAzMy43VjIxNGwtOTYuNiAzNi4yQzkuMyAyNTUuNSAwIDI2OC45IDAgMjgzLjlWMzk0YzAgMTMuNiA3LjcgMjYuMSAxOS45IDMyLjJsMTAwIDUwYzEwLjEgNS4xIDIyLjEgNS4xIDMyLjIgMGwxMDMuOS01MiAxMDMuOSA1MmMxMC4xIDUuMSAyMi4xIDUuMSAzMi4yIDBsMTAwLTUwYzEyLjItNi4xIDE5LjktMTguNiAxOS45LTMyLjJWMjgzLjljMC0xNS05LjMtMjguNC0yMy40LTMzLjd6TTM1OCAyMTQuOGwtODUgMzEuOXYtNjguMmw4NS0zN3Y3My4zek0xNTQgMTA0LjFsMTAyLTM4LjIgMTAyIDM4LjJ2LjZsLTEwMiA0MS40LTEwMi00MS40di0uNnptODQgMjkxLjFsLTg1IDQyLjV2LTc5LjFsODUtMzguOHY3NS40em0wLTExMmwtMTAyIDQxLjQtMTAyLTQxLjR2LS42bDEwMi0zOC4yIDEwMiAzOC4ydi42em0yNDAgMTEybC04NSA0Mi41di03OS4xbDg1LTM4Ljh2NzUuNHptMC0xMTJsLTEwMiA0MS40LTEwMi00MS40di0uNmwxMDItMzguMiAxMDIgMzguMnYuNnoiPjwvcGF0aD48L3N2Zz4K" height="20">](https://docs.rs/itoa)
+[<img alt="build status" src="https://img.shields.io/github/workflow/status/dtolnay/itoa/CI/master?style=for-the-badge" height="20">](https://github.com/dtolnay/itoa/actions?query=branch%3Amaster)
+
+This crate provides a fast conversion of integer primitives to decimal strings.
+The implementation comes straight from [libcore] but avoids the performance
+penalty of going through [`core::fmt::Formatter`].
+
+See also [`ryu`] for printing floating point primitives.
+
+*Version requirement: rustc 1.36+*
+
+[libcore]: https://github.com/rust-lang/rust/blob/b8214dc6c6fc20d0a660fb5700dca9ebf51ebe89/src/libcore/fmt/num.rs#L201-L254
+[`core::fmt::Formatter`]: https://doc.rust-lang.org/std/fmt/struct.Formatter.html
+[`ryu`]: https://github.com/dtolnay/ryu
+
+```toml
+[dependencies]
+itoa = "1.0"
+```
+
+<br>
+
+## Example
+
+```rust
+fn main() {
+ let mut buffer = itoa::Buffer::new();
+ let printed = buffer.format(128u64);
+ assert_eq!(printed, "128");
+}
+```
+
+<br>
+
+## Performance (lower is better)
+
+![performance](https://raw.githubusercontent.com/dtolnay/itoa/master/performance.png)
+
+<br>
+
+#### License
+
+<sup>
+Licensed under either of <a href="LICENSE-APACHE">Apache License, Version
+2.0</a> or <a href="LICENSE-MIT">MIT license</a> at your option.
+</sup>
+
+<br>
+
+<sub>
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in this crate by you, as defined in the Apache-2.0 license, shall
+be dual licensed as above, without any additional terms or conditions.
+</sub>
diff --git a/vendor/itoa/benches/bench.rs b/vendor/itoa/benches/bench.rs
new file mode 100644
index 000000000..acd2a0c1e
--- /dev/null
+++ b/vendor/itoa/benches/bench.rs
@@ -0,0 +1,55 @@
+#![feature(test)]
+#![allow(non_snake_case)]
+#![allow(clippy::cast_lossless)]
+
+extern crate test;
+
+macro_rules! benches {
+ ($($name:ident($value:expr))*) => {
+ mod bench_itoa_format {
+ use test::{Bencher, black_box};
+
+ $(
+ #[bench]
+ fn $name(b: &mut Bencher) {
+ let mut buffer = itoa::Buffer::new();
+
+ b.iter(|| {
+ let printed = buffer.format(black_box($value));
+ black_box(printed);
+ });
+ }
+ )*
+ }
+
+ mod bench_std_fmt {
+ use std::io::Write;
+ use test::{Bencher, black_box};
+
+ $(
+ #[bench]
+ fn $name(b: &mut Bencher) {
+ let mut buf = Vec::with_capacity(40);
+
+ b.iter(|| {
+ buf.clear();
+ write!(&mut buf, "{}", black_box($value)).unwrap();
+ black_box(&buf);
+ });
+ }
+ )*
+ }
+ }
+}
+
+benches! {
+ bench_u64_0(0u64)
+ bench_u64_half(u32::max_value() as u64)
+ bench_u64_max(u64::max_value())
+
+ bench_i16_0(0i16)
+ bench_i16_min(i16::min_value())
+
+ bench_u128_0(0u128)
+ bench_u128_max(u128::max_value())
+}
diff --git a/vendor/itoa/src/lib.rs b/vendor/itoa/src/lib.rs
new file mode 100644
index 000000000..86604aa2a
--- /dev/null
+++ b/vendor/itoa/src/lib.rs
@@ -0,0 +1,284 @@
+//! [![github]](https://github.com/dtolnay/itoa)&ensp;[![crates-io]](https://crates.io/crates/itoa)&ensp;[![docs-rs]](https://docs.rs/itoa)
+//!
+//! [github]: https://img.shields.io/badge/github-8da0cb?style=for-the-badge&labelColor=555555&logo=github
+//! [crates-io]: https://img.shields.io/badge/crates.io-fc8d62?style=for-the-badge&labelColor=555555&logo=rust
+//! [docs-rs]: https://img.shields.io/badge/docs.rs-66c2a5?style=for-the-badge&labelColor=555555&logoColor=white&logo=data:image/svg+xml;base64,PHN2ZyByb2xlPSJpbWciIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmlld0JveD0iMCAwIDUxMiA1MTIiPjxwYXRoIGZpbGw9IiNmNWY1ZjUiIGQ9Ik00ODguNiAyNTAuMkwzOTIgMjE0VjEwNS41YzAtMTUtOS4zLTI4LjQtMjMuNC0zMy43bC0xMDAtMzcuNWMtOC4xLTMuMS0xNy4xLTMuMS0yNS4zIDBsLTEwMCAzNy41Yy0xNC4xIDUuMy0yMy40IDE4LjctMjMuNCAzMy43VjIxNGwtOTYuNiAzNi4yQzkuMyAyNTUuNSAwIDI2OC45IDAgMjgzLjlWMzk0YzAgMTMuNiA3LjcgMjYuMSAxOS45IDMyLjJsMTAwIDUwYzEwLjEgNS4xIDIyLjEgNS4xIDMyLjIgMGwxMDMuOS01MiAxMDMuOSA1MmMxMC4xIDUuMSAyMi4xIDUuMSAzMi4yIDBsMTAwLTUwYzEyLjItNi4xIDE5LjktMTguNiAxOS45LTMyLjJWMjgzLjljMC0xNS05LjMtMjguNC0yMy40LTMzLjd6TTM1OCAyMTQuOGwtODUgMzEuOXYtNjguMmw4NS0zN3Y3My4zek0xNTQgMTA0LjFsMTAyLTM4LjIgMTAyIDM4LjJ2LjZsLTEwMiA0MS40LTEwMi00MS40di0uNnptODQgMjkxLjFsLTg1IDQyLjV2LTc5LjFsODUtMzguOHY3NS40em0wLTExMmwtMTAyIDQxLjQtMTAyLTQxLjR2LS42bDEwMi0zOC4yIDEwMiAzOC4ydi42em0yNDAgMTEybC04NSA0Mi41di03OS4xbDg1LTM4Ljh2NzUuNHptMC0xMTJsLTEwMiA0MS40LTEwMi00MS40di0uNmwxMDItMzguMiAxMDIgMzguMnYuNnoiPjwvcGF0aD48L3N2Zz4K
+//!
+//! <br>
+//!
+//! This crate provides a fast conversion of integer primitives to decimal
+//! strings. The implementation comes straight from [libcore] but avoids the
+//! performance penalty of going through [`core::fmt::Formatter`].
+//!
+//! See also [`ryu`] for printing floating point primitives.
+//!
+//! [libcore]: https://github.com/rust-lang/rust/blob/b8214dc6c6fc20d0a660fb5700dca9ebf51ebe89/src/libcore/fmt/num.rs#L201-L254
+//! [`core::fmt::Formatter`]: https://doc.rust-lang.org/std/fmt/struct.Formatter.html
+//! [`ryu`]: https://github.com/dtolnay/ryu
+//!
+//! # Example
+//!
+//! ```
+//! fn main() {
+//! let mut buffer = itoa::Buffer::new();
+//! let printed = buffer.format(128u64);
+//! assert_eq!(printed, "128");
+//! }
+//! ```
+//!
+//! # Performance (lower is better)
+//!
+//! ![performance](https://raw.githubusercontent.com/dtolnay/itoa/master/performance.png)
+
+#![doc(html_root_url = "https://docs.rs/itoa/1.0.2")]
+#![no_std]
+#![allow(
+ clippy::cast_lossless,
+ clippy::cast_possible_truncation,
+ clippy::must_use_candidate,
+ clippy::unreadable_literal
+)]
+
+mod udiv128;
+
+use core::mem::{self, MaybeUninit};
+use core::{ptr, slice, str};
+
+/// A correctly sized stack allocation for the formatted integer to be written
+/// into.
+///
+/// # Example
+///
+/// ```
+/// let mut buffer = itoa::Buffer::new();
+/// let printed = buffer.format(1234);
+/// assert_eq!(printed, "1234");
+/// ```
+pub struct Buffer {
+ bytes: [MaybeUninit<u8>; I128_MAX_LEN],
+}
+
+impl Default for Buffer {
+ #[inline]
+ fn default() -> Buffer {
+ Buffer::new()
+ }
+}
+
+impl Clone for Buffer {
+ #[inline]
+ fn clone(&self) -> Self {
+ Buffer::new()
+ }
+}
+
+impl Buffer {
+ /// This is a cheap operation; you don't need to worry about reusing buffers
+ /// for efficiency.
+ #[inline]
+ pub fn new() -> Buffer {
+ let bytes = [MaybeUninit::<u8>::uninit(); I128_MAX_LEN];
+ Buffer { bytes }
+ }
+
+ /// Print an integer into this buffer and return a reference to its string
+ /// representation within the buffer.
+ pub fn format<I: Integer>(&mut self, i: I) -> &str {
+ i.write(unsafe {
+ &mut *(&mut self.bytes as *mut [MaybeUninit<u8>; I128_MAX_LEN]
+ as *mut <I as private::Sealed>::Buffer)
+ })
+ }
+}
+
+/// An integer that can be written into an [`itoa::Buffer`][Buffer].
+///
+/// This trait is sealed and cannot be implemented for types outside of itoa.
+pub trait Integer: private::Sealed {}
+
+// Seal to prevent downstream implementations of the Integer trait.
+mod private {
+ pub trait Sealed: Copy {
+ type Buffer: 'static;
+ fn write(self, buf: &mut Self::Buffer) -> &str;
+ }
+}
+
+const DEC_DIGITS_LUT: &[u8] = b"\
+ 0001020304050607080910111213141516171819\
+ 2021222324252627282930313233343536373839\
+ 4041424344454647484950515253545556575859\
+ 6061626364656667686970717273747576777879\
+ 8081828384858687888990919293949596979899";
+
+// Adaptation of the original implementation at
+// https://github.com/rust-lang/rust/blob/b8214dc6c6fc20d0a660fb5700dca9ebf51ebe89/src/libcore/fmt/num.rs#L188-L266
+macro_rules! impl_Integer {
+ ($($max_len:expr => $t:ident),* as $conv_fn:ident) => {$(
+ impl Integer for $t {}
+
+ impl private::Sealed for $t {
+ type Buffer = [MaybeUninit<u8>; $max_len];
+
+ #[allow(unused_comparisons)]
+ #[inline]
+ fn write(self, buf: &mut [MaybeUninit<u8>; $max_len]) -> &str {
+ let is_nonnegative = self >= 0;
+ let mut n = if is_nonnegative {
+ self as $conv_fn
+ } else {
+ // convert the negative num to positive by summing 1 to it's 2 complement
+ (!(self as $conv_fn)).wrapping_add(1)
+ };
+ let mut curr = buf.len() as isize;
+ let buf_ptr = buf.as_mut_ptr() as *mut u8;
+ let lut_ptr = DEC_DIGITS_LUT.as_ptr();
+
+ unsafe {
+ // need at least 16 bits for the 4-characters-at-a-time to work.
+ if mem::size_of::<$t>() >= 2 {
+ // eagerly decode 4 characters at a time
+ while n >= 10000 {
+ let rem = (n % 10000) as isize;
+ n /= 10000;
+
+ let d1 = (rem / 100) << 1;
+ let d2 = (rem % 100) << 1;
+ curr -= 4;
+ ptr::copy_nonoverlapping(lut_ptr.offset(d1), buf_ptr.offset(curr), 2);
+ ptr::copy_nonoverlapping(lut_ptr.offset(d2), buf_ptr.offset(curr + 2), 2);
+ }
+ }
+
+ // if we reach here numbers are <= 9999, so at most 4 chars long
+ let mut n = n as isize; // possibly reduce 64bit math
+
+ // decode 2 more chars, if > 2 chars
+ if n >= 100 {
+ let d1 = (n % 100) << 1;
+ n /= 100;
+ curr -= 2;
+ ptr::copy_nonoverlapping(lut_ptr.offset(d1), buf_ptr.offset(curr), 2);
+ }
+
+ // decode last 1 or 2 chars
+ if n < 10 {
+ curr -= 1;
+ *buf_ptr.offset(curr) = (n as u8) + b'0';
+ } else {
+ let d1 = n << 1;
+ curr -= 2;
+ ptr::copy_nonoverlapping(lut_ptr.offset(d1), buf_ptr.offset(curr), 2);
+ }
+
+ if !is_nonnegative {
+ curr -= 1;
+ *buf_ptr.offset(curr) = b'-';
+ }
+ }
+
+ let len = buf.len() - curr as usize;
+ let bytes = unsafe { slice::from_raw_parts(buf_ptr.offset(curr), len) };
+ unsafe { str::from_utf8_unchecked(bytes) }
+ }
+ }
+ )*};
+}
+
+const I8_MAX_LEN: usize = 4;
+const U8_MAX_LEN: usize = 3;
+const I16_MAX_LEN: usize = 6;
+const U16_MAX_LEN: usize = 5;
+const I32_MAX_LEN: usize = 11;
+const U32_MAX_LEN: usize = 10;
+const I64_MAX_LEN: usize = 20;
+const U64_MAX_LEN: usize = 20;
+
+impl_Integer!(
+ I8_MAX_LEN => i8,
+ U8_MAX_LEN => u8,
+ I16_MAX_LEN => i16,
+ U16_MAX_LEN => u16,
+ I32_MAX_LEN => i32,
+ U32_MAX_LEN => u32
+ as u32);
+
+impl_Integer!(I64_MAX_LEN => i64, U64_MAX_LEN => u64 as u64);
+
+#[cfg(target_pointer_width = "16")]
+impl_Integer!(I16_MAX_LEN => isize, U16_MAX_LEN => usize as u16);
+
+#[cfg(target_pointer_width = "32")]
+impl_Integer!(I32_MAX_LEN => isize, U32_MAX_LEN => usize as u32);
+
+#[cfg(target_pointer_width = "64")]
+impl_Integer!(I64_MAX_LEN => isize, U64_MAX_LEN => usize as u64);
+
+macro_rules! impl_Integer128 {
+ ($($max_len:expr => $t:ident),*) => {$(
+ impl Integer for $t {}
+
+ impl private::Sealed for $t {
+ type Buffer = [MaybeUninit<u8>; $max_len];
+
+ #[allow(unused_comparisons)]
+ #[inline]
+ fn write(self, buf: &mut [MaybeUninit<u8>; $max_len]) -> &str {
+ let is_nonnegative = self >= 0;
+ let n = if is_nonnegative {
+ self as u128
+ } else {
+ // convert the negative num to positive by summing 1 to it's 2 complement
+ (!(self as u128)).wrapping_add(1)
+ };
+ let mut curr = buf.len() as isize;
+ let buf_ptr = buf.as_mut_ptr() as *mut u8;
+
+ unsafe {
+ // Divide by 10^19 which is the highest power less than 2^64.
+ let (n, rem) = udiv128::udivmod_1e19(n);
+ let buf1 = buf_ptr.offset(curr - U64_MAX_LEN as isize) as *mut [MaybeUninit<u8>; U64_MAX_LEN];
+ curr -= rem.write(&mut *buf1).len() as isize;
+
+ if n != 0 {
+ // Memset the base10 leading zeros of rem.
+ let target = buf.len() as isize - 19;
+ ptr::write_bytes(buf_ptr.offset(target), b'0', (curr - target) as usize);
+ curr = target;
+
+ // Divide by 10^19 again.
+ let (n, rem) = udiv128::udivmod_1e19(n);
+ let buf2 = buf_ptr.offset(curr - U64_MAX_LEN as isize) as *mut [MaybeUninit<u8>; U64_MAX_LEN];
+ curr -= rem.write(&mut *buf2).len() as isize;
+
+ if n != 0 {
+ // Memset the leading zeros.
+ let target = buf.len() as isize - 38;
+ ptr::write_bytes(buf_ptr.offset(target), b'0', (curr - target) as usize);
+ curr = target;
+
+ // There is at most one digit left
+ // because u128::max / 10^19 / 10^19 is 3.
+ curr -= 1;
+ *buf_ptr.offset(curr) = (n as u8) + b'0';
+ }
+ }
+
+ if !is_nonnegative {
+ curr -= 1;
+ *buf_ptr.offset(curr) = b'-';
+ }
+
+ let len = buf.len() - curr as usize;
+ let bytes = slice::from_raw_parts(buf_ptr.offset(curr), len);
+ str::from_utf8_unchecked(bytes)
+ }
+ }
+ }
+ )*};
+}
+
+const U128_MAX_LEN: usize = 39;
+const I128_MAX_LEN: usize = 40;
+
+impl_Integer128!(I128_MAX_LEN => i128, U128_MAX_LEN => u128);
diff --git a/vendor/itoa/src/udiv128.rs b/vendor/itoa/src/udiv128.rs
new file mode 100644
index 000000000..df53eb526
--- /dev/null
+++ b/vendor/itoa/src/udiv128.rs
@@ -0,0 +1,43 @@
+/// Multiply unsigned 128 bit integers, return upper 128 bits of the result
+#[inline]
+fn u128_mulhi(x: u128, y: u128) -> u128 {
+ let x_lo = x as u64;
+ let x_hi = (x >> 64) as u64;
+ let y_lo = y as u64;
+ let y_hi = (y >> 64) as u64;
+
+ // handle possibility of overflow
+ let carry = (x_lo as u128 * y_lo as u128) >> 64;
+ let m = x_lo as u128 * y_hi as u128 + carry;
+ let high1 = m >> 64;
+
+ let m_lo = m as u64;
+ let high2 = (x_hi as u128 * y_lo as u128 + m_lo as u128) >> 64;
+
+ x_hi as u128 * y_hi as u128 + high1 + high2
+}
+
+/// Divide `n` by 1e19 and return quotient and remainder
+///
+/// Integer division algorithm is based on the following paper:
+///
+/// T. Granlund and P. Montgomery, “Division by Invariant Integers Using Multiplication”
+/// in Proc. of the SIGPLAN94 Conference on Programming Language Design and
+/// Implementation, 1994, pp. 61–72
+///
+#[inline]
+pub fn udivmod_1e19(n: u128) -> (u128, u64) {
+ let d = 10_000_000_000_000_000_000_u64; // 10^19
+
+ let quot = if n < 1 << 83 {
+ ((n >> 19) as u64 / (d >> 19)) as u128
+ } else {
+ u128_mulhi(n, 156927543384667019095894735580191660403) >> 62
+ };
+
+ let rem = (n - quot * d as u128) as u64;
+ debug_assert_eq!(quot, n / d as u128);
+ debug_assert_eq!(rem as u128, n % d as u128);
+
+ (quot, rem)
+}
diff --git a/vendor/itoa/tests/test.rs b/vendor/itoa/tests/test.rs
new file mode 100644
index 000000000..1d7e8cb60
--- /dev/null
+++ b/vendor/itoa/tests/test.rs
@@ -0,0 +1,29 @@
+#![allow(non_snake_case)]
+#![allow(clippy::cast_lossless)]
+
+macro_rules! test {
+ ($($name:ident($value:expr, $expected:expr))*) => {
+ $(
+ #[test]
+ fn $name() {
+ let mut buffer = itoa::Buffer::new();
+ let s = buffer.format($value);
+ assert_eq!(s, $expected);
+ }
+ )*
+ }
+}
+
+test! {
+ test_u64_0(0u64, "0")
+ test_u64_half(u32::max_value() as u64, "4294967295")
+ test_u64_max(u64::max_value(), "18446744073709551615")
+ test_i64_min(i64::min_value(), "-9223372036854775808")
+
+ test_i16_0(0i16, "0")
+ test_i16_min(i16::min_value(), "-32768")
+
+ test_u128_0(0u128, "0")
+ test_u128_max(u128::max_value(), "340282366920938463463374607431768211455")
+ test_i128_min(i128::min_value(), "-170141183460469231731687303715884105728")
+}