summaryrefslogtreecommitdiffstats
path: root/vendor/jod-thread/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/jod-thread/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/jod-thread/Cargo.toml')
-rw-r--r--vendor/jod-thread/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/vendor/jod-thread/Cargo.toml b/vendor/jod-thread/Cargo.toml
new file mode 100644
index 000000000..901bed2e2
--- /dev/null
+++ b/vendor/jod-thread/Cargo.toml
@@ -0,0 +1,24 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "jod-thread"
+version = "0.1.2"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
+description = "std::thread which joins on drop by default."
+documentation = "https://docs.rs/jod-thread"
+readme = "README.md"
+keywords = ["thread", "join", "structured", "concurrency"]
+categories = ["rust-patterns", "concurrency"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/jod-thread"