summaryrefslogtreecommitdiffstats
path: root/vendor/js-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
commit9918693037dce8aa4bb6f08741b6812923486c18 (patch)
tree21d2b40bec7e6a7ea664acee056eb3d08e15a1cf /vendor/js-sys/Cargo.toml
parentReleasing progress-linux version 1.75.0+dfsg1-5~progress7.99u1. (diff)
downloadrustc-9918693037dce8aa4bb6f08741b6812923486c18.tar.xz
rustc-9918693037dce8aa4bb6f08741b6812923486c18.zip
Merging upstream version 1.76.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/js-sys/Cargo.toml')
-rw-r--r--vendor/js-sys/Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/vendor/js-sys/Cargo.toml b/vendor/js-sys/Cargo.toml
index 2036a4c62..79f6e3e51 100644
--- a/vendor/js-sys/Cargo.toml
+++ b/vendor/js-sys/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2018"
-rust-version = "1.56"
+rust-version = "1.57"
name = "js-sys"
-version = "0.3.64"
+version = "0.3.66"
authors = ["The wasm-bindgen Developers"]
description = """
Bindings for all JS global objects and functions in all JS environments like
@@ -23,7 +23,7 @@ homepage = "https://rustwasm.github.io/wasm-bindgen/"
documentation = "https://docs.rs/js-sys"
readme = "./README.md"
categories = ["wasm"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/rustwasm/wasm-bindgen/tree/master/crates/js-sys"
resolver = "2"
@@ -32,16 +32,16 @@ test = false
doctest = false
[dependencies.wasm-bindgen]
-version = "0.2.87"
+version = "0.2.89"
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-futures]
-version = "0.4.37"
+version = "0.4.39"
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "=0.3.37"
+version = "=0.3.39"
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.web-sys]
-version = "0.3.64"
+version = "0.3.66"
features = [
"Headers",
"Response",