summaryrefslogtreecommitdiffstats
path: root/vendor/libgit2-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/libgit2-sys/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libgit2-sys/Cargo.toml')
-rw-r--r--vendor/libgit2-sys/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/vendor/libgit2-sys/Cargo.toml b/vendor/libgit2-sys/Cargo.toml
new file mode 100644
index 000000000..abfaf8441
--- /dev/null
+++ b/vendor/libgit2-sys/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "libgit2-sys"
+version = "0.15.0+1.6.3"
+authors = [
+ "Josh Triplett <josh@joshtriplett.org>",
+ "Alex Crichton <alex@alexcrichton.com>",
+]
+build = "build.rs"
+links = "git2"
+exclude = [
+ "libgit2/ci/*",
+ "libgit2/docs/*",
+ "libgit2/examples/*",
+ "libgit2/fuzzers/*",
+ "libgit2/tests/*",
+]
+description = "Native bindings to the libgit2 library"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/git2-rs"
+
+[lib]
+name = "libgit2_sys"
+path = "lib.rs"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.libssh2-sys]
+version = "0.3.0"
+optional = true
+
+[dependencies.libz-sys]
+version = "1.1.0"
+features = ["libc"]
+default-features = false
+
+[build-dependencies.cc]
+version = "1.0.43"
+features = ["parallel"]
+
+[build-dependencies.pkg-config]
+version = "0.3.7"
+
+[features]
+https = ["openssl-sys"]
+ssh = ["libssh2-sys"]
+ssh_key_from_memory = []
+vendored = []
+vendored-openssl = ["openssl-sys/vendored"]
+zlib-ng-compat = [
+ "libz-sys/zlib-ng",
+ "libssh2-sys?/zlib-ng-compat",
+]
+
+[target."cfg(unix)".dependencies.openssl-sys]
+version = "0.9"
+optional = true