summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/libz-sys/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libz-sys/Cargo.toml')
-rw-r--r--vendor/libz-sys/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/vendor/libz-sys/Cargo.toml b/vendor/libz-sys/Cargo.toml
new file mode 100644
index 000000000..6296ed48b
--- /dev/null
+++ b/vendor/libz-sys/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "libz-sys"
+version = "1.1.3"
+authors = ["Alex Crichton <alex@alexcrichton.com>", "Josh Triplett <josh@joshtriplett.org>"]
+build = "build.rs"
+links = "z"
+description = "Low-level bindings to the system libz library (also known as zlib).\n"
+documentation = "https://docs.rs/libz-sys"
+keywords = ["zlib", "zlib-ng"]
+categories = ["compression", "external-ffi-bindings"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/libz-sys"
+[dependencies.libc]
+version = "0.2.43"
+optional = true
+[build-dependencies.cc]
+version = "1.0.18"
+
+[build-dependencies.cmake]
+version = "0.1.44"
+optional = true
+
+[build-dependencies.pkg-config]
+version = "0.3.9"
+
+[features]
+asm = []
+default = ["libc", "stock-zlib"]
+static = []
+stock-zlib = []
+zlib-ng = ["libc", "cmake"]
+[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+version = "0.2"