summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/ci/run-docker.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/libz-sys/ci/run-docker.sh
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libz-sys/ci/run-docker.sh')
-rwxr-xr-xvendor/libz-sys/ci/run-docker.sh19
1 files changed, 0 insertions, 19 deletions
diff --git a/vendor/libz-sys/ci/run-docker.sh b/vendor/libz-sys/ci/run-docker.sh
deleted file mode 100755
index 73a0847d5..000000000
--- a/vendor/libz-sys/ci/run-docker.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-set -ex
-
-mkdir -p target
-
-docker build --rm -t libz-sys-ci ci
-docker run \
- --rm \
- --init \
- --user $(id -u):$(id -g) \
- --volume `rustc --print sysroot`:/usr/local:ro \
- --volume `pwd`:/src:ro \
- --volume `pwd`/target:/src/target \
- --workdir /src \
- --env CARGO_HOME=/cargo \
- --volume $HOME/.cargo:/cargo \
- -it \
- libz-sys-ci \
- cargo run --manifest-path systest/Cargo.toml -vv