summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/ci/test.bash
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/libz-sys/ci/test.bash
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libz-sys/ci/test.bash')
-rwxr-xr-xvendor/libz-sys/ci/test.bash36
1 files changed, 0 insertions, 36 deletions
diff --git a/vendor/libz-sys/ci/test.bash b/vendor/libz-sys/ci/test.bash
deleted file mode 100755
index d7b4c743c..000000000
--- a/vendor/libz-sys/ci/test.bash
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/env bash
-# Script for building your rust projects.
-set -e
-
-required_arg() {
- if [ -z "$1" ]; then
- echo "Required argument $2 missing"
- exit 1
- fi
-}
-
-# $1 {path} = Path to cross/cargo executable
-CROSS=$1
-# $2 {string} = <Target Triple>
-TARGET_TRIPLE=$2
-
-required_arg $CROSS 'CROSS'
-required_arg $TARGET_TRIPLE '<Target Triple>'
-
-if [ "${TARGET_TRIPLE%-windows-gnu}" != "$TARGET_TRIPLE" ]; then
- # On windows-gnu targets, we need to set the PATH to include MinGW
- if [ "${TARGET_TRIPLE#x86_64-}" != "$TARGET_TRIPLE" ]; then
- PATH=/c/msys64/mingw64/bin:/c/msys64/usr/bin:$PATH
- elif [ "${TARGET_TRIPLE#i?86-}" != "$TARGET_TRIPLE" ]; then
- PATH=/c/msys64/mingw32/bin:/c/msys64/usr/bin:$PATH
- else
- echo Unknown windows-gnu target
- exit 1
- fi
-fi
-
-$CROSS test --target $TARGET_TRIPLE
-$CROSS run --target $TARGET_TRIPLE --manifest-path systest/Cargo.toml
-echo === zlib-ng build ===
-$CROSS test --target $TARGET_TRIPLE --no-default-features --features zlib-ng
-$CROSS run --target $TARGET_TRIPLE --manifest-path systest/Cargo.toml --no-default-features --features zlib-ng