summaryrefslogtreecommitdiffstats
path: root/vendor/linux-raw-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/linux-raw-sys/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/linux-raw-sys/Cargo.toml')
-rw-r--r--vendor/linux-raw-sys/Cargo.toml11
1 files changed, 8 insertions, 3 deletions
diff --git a/vendor/linux-raw-sys/Cargo.toml b/vendor/linux-raw-sys/Cargo.toml
index 3152a977e..294522164 100644
--- a/vendor/linux-raw-sys/Cargo.toml
+++ b/vendor/linux-raw-sys/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.48"
+edition = "2021"
+rust-version = "1.63"
name = "linux-raw-sys"
-version = "0.3.4"
+version = "0.4.3"
authors = ["Dan Gohman <dev@sunfishcode.online>"]
exclude = [
"/gen",
@@ -65,12 +65,17 @@ default = [
]
errno = []
general = []
+if_ether = []
+io_uring = []
ioctl = []
+net = []
netlink = []
no_std = []
+prctl = []
rustc-dep-of-std = [
"core",
"compiler_builtins",
"no_std",
]
std = []
+system = []