summaryrefslogtreecommitdiffstats
path: root/vendor/litemap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/litemap/Cargo.toml
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/litemap/Cargo.toml')
-rw-r--r--vendor/litemap/Cargo.toml110
1 files changed, 110 insertions, 0 deletions
diff --git a/vendor/litemap/Cargo.toml b/vendor/litemap/Cargo.toml
new file mode 100644
index 000000000..315056b05
--- /dev/null
+++ b/vendor/litemap/Cargo.toml
@@ -0,0 +1,110 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "litemap"
+version = "0.6.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "A key-value Map implementation based on a flat, sorted Vec."
+documentation = "https://docs.rs/litemap"
+readme = "./README.md"
+keywords = [
+ "sorted",
+ "vec",
+ "map",
+ "hashmap",
+ "btreemap",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[example]]
+name = "litemap_bincode"
+path = "benches/bin/litemap_bincode.rs"
+required-features = ["serde"]
+
+[[example]]
+name = "litemap_postcard"
+path = "benches/bin/litemap_postcard.rs"
+required-features = ["serde"]
+
+[[test]]
+name = "serde"
+required-features = ["serde"]
+
+[[test]]
+name = "store"
+required-features = ["testing"]
+
+[[bench]]
+name = "litemap"
+harness = false
+required-features = ["serde"]
+
+[dependencies.serde]
+version = "1"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.yoke]
+version = "0.6.0"
+features = ["derive"]
+optional = true
+
+[dev-dependencies.bincode]
+version = "1"
+
+[dev-dependencies.bytecheck]
+version = "0.6"
+
+[dev-dependencies.criterion]
+version = "0.3.4"
+
+[dev-dependencies.icu_benchmark_macros]
+version = "0.7"
+
+[dev-dependencies.icu_locid]
+version = "1.0.0-beta1"
+
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["use-std"]
+
+[dev-dependencies.rkyv]
+version = "0.7"
+features = ["validation"]
+
+[dev-dependencies.serde]
+version = "1"
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[features]
+alloc = []
+bench = []
+default = ["alloc"]
+testing = ["alloc"]