summaryrefslogtreecommitdiffstats
path: root/vendor/litemap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/litemap/Cargo.toml
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/litemap/Cargo.toml')
-rw-r--r--vendor/litemap/Cargo.toml34
1 files changed, 22 insertions, 12 deletions
diff --git a/vendor/litemap/Cargo.toml b/vendor/litemap/Cargo.toml
index a08c685a2..452cd5e5f 100644
--- a/vendor/litemap/Cargo.toml
+++ b/vendor/litemap/Cargo.toml
@@ -11,10 +11,12 @@
[package]
edition = "2021"
+rust-version = "1.66"
name = "litemap"
-version = "0.7.0"
+version = "0.7.1"
authors = ["The ICU4X Project Developers"]
include = [
+ "data/**/*",
"src/**/*",
"examples/**/*",
"benches/**/*",
@@ -25,7 +27,7 @@ include = [
]
description = "A key-value Map implementation based on a flat, sorted Vec."
documentation = "https://docs.rs/litemap"
-readme = "./README.md"
+readme = "README.md"
keywords = [
"sorted",
"vec",
@@ -33,26 +35,29 @@ keywords = [
"hashmap",
"btreemap",
]
-license = "Unicode-DFS-2016"
+license-file = "LICENSE"
repository = "https://github.com/unicode-org/icu4x"
-[package.metadata.workspaces]
-independent = true
+[package.metadata.cargo-all-features]
+denylist = ["bench"]
[package.metadata.docs.rs]
all-features = true
-[package.metadata.cargo-all-features]
-denylist = ["bench"]
+[package.metadata.workspaces]
+independent = true
+
+[lib]
+bench = false
[[example]]
name = "litemap_bincode"
-path = "benches/bin/litemap_bincode.rs"
+path = "examples/litemap_bincode.rs"
required-features = ["serde"]
[[example]]
name = "litemap_postcard"
-path = "benches/bin/litemap_postcard.rs"
+path = "examples/litemap_postcard.rs"
required-features = ["serde"]
[[test]]
@@ -78,6 +83,7 @@ default-features = false
version = "0.7.1"
features = ["derive"]
optional = true
+default-features = false
[dev-dependencies.bincode]
version = "1"
@@ -85,8 +91,9 @@ version = "1"
[dev-dependencies.bytecheck]
version = "0.6"
-[dev-dependencies.criterion]
-version = "0.4"
+[dev-dependencies.icu_locid]
+version = "~1.2.0"
+default-features = false
[dev-dependencies.postcard]
version = "1.0.0"
@@ -105,6 +112,9 @@ version = "1"
[features]
alloc = []
-bench = []
+bench = ["serde"]
default = ["alloc"]
testing = ["alloc"]
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.4"