summaryrefslogtreecommitdiffstats
path: root/vendor/lzma-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/lzma-sys/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/lzma-sys/Cargo.toml')
-rw-r--r--vendor/lzma-sys/Cargo.toml20
1 files changed, 13 insertions, 7 deletions
diff --git a/vendor/lzma-sys/Cargo.toml b/vendor/lzma-sys/Cargo.toml
index 2744e3b92..a006799a9 100644
--- a/vendor/lzma-sys/Cargo.toml
+++ b/vendor/lzma-sys/Cargo.toml
@@ -3,28 +3,34 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "lzma-sys"
-version = "0.1.17"
+version = "0.1.20"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "lzma"
-description = "Raw bindings to liblzma which contains an implementation of LZMA and xz stream\nencoding/decoding.\n\nHigh level Rust bindings are available in the `xz2` crate.\n"
+description = """
+Raw bindings to liblzma which contains an implementation of LZMA and xz stream
+encoding/decoding.
+
+High level Rust bindings are available in the `xz2` crate.
+"""
homepage = "https://github.com/alexcrichton/xz2-rs"
documentation = "https://docs.rs/lzma-sys"
categories = ["external-ffi-bindings"]
license = "MIT/Apache-2.0"
repository = "https://github.com/alexcrichton/xz2-rs"
+
[dependencies.libc]
version = "0.2.51"
+
[build-dependencies.cc]
version = "1.0.34"