summaryrefslogtreecommitdiffstats
path: root/vendor/nohash-hasher/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
commita0b8f38ab54ac451646aa00cd5e91b6c76f22a84 (patch)
treefc451898ccaf445814e26b46664d78702178101d /vendor/nohash-hasher/Cargo.toml
parentAdding debian version 1.71.1+dfsg1-2. (diff)
downloadrustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.tar.xz
rustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/nohash-hasher/Cargo.toml')
-rw-r--r--vendor/nohash-hasher/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/vendor/nohash-hasher/Cargo.toml b/vendor/nohash-hasher/Cargo.toml
new file mode 100644
index 000000000..e065d800a
--- /dev/null
+++ b/vendor/nohash-hasher/Cargo.toml
@@ -0,0 +1,26 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "nohash-hasher"
+version = "0.2.0"
+authors = ["Parity Technologies <admin@parity.io>"]
+description = "An implementation of `std::hash::Hasher` which does not hash at all."
+readme = "README.md"
+keywords = ["hash", "hasher", "hashmap", "hashset"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/paritytech/nohash-hasher"
+
+[features]
+default = ["std"]
+std = []