summaryrefslogtreecommitdiffstats
path: root/vendor/nom/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/nom/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/nom/Cargo.toml')
-rw-r--r--vendor/nom/Cargo.toml54
1 files changed, 46 insertions, 8 deletions
diff --git a/vendor/nom/Cargo.toml b/vendor/nom/Cargo.toml
index 6e38fa0db..2388b4cee 100644
--- a/vendor/nom/Cargo.toml
+++ b/vendor/nom/Cargo.toml
@@ -11,32 +11,65 @@
[package]
edition = "2018"
+rust-version = "1.48"
name = "nom"
-version = "7.1.0"
+version = "7.1.3"
authors = ["contact@geoffroycouprie.com"]
-include = ["CHANGELOG.md", "LICENSE", "README.md", ".gitignore", "Cargo.toml", "src/*.rs", "src/*/*.rs", "tests/*.rs", "doc/nom_recipes.md", "build.rs"]
+include = [
+ "CHANGELOG.md",
+ "LICENSE",
+ "README.md",
+ ".gitignore",
+ "Cargo.toml",
+ "src/*.rs",
+ "src/*/*.rs",
+ "tests/*.rs",
+ "doc/nom_recipes.md",
+]
autoexamples = false
description = "A byte-oriented, zero-copy, parser combinators library"
documentation = "https://docs.rs/nom"
readme = "README.md"
-keywords = ["parser", "parser-combinators", "parsing", "streaming", "bit"]
+keywords = [
+ "parser",
+ "parser-combinators",
+ "parsing",
+ "streaming",
+ "bit",
+]
categories = ["parsing"]
license = "MIT"
repository = "https://github.com/Geal/nom"
+
[package.metadata.docs.rs]
+features = [
+ "alloc",
+ "std",
+ "docsrs",
+]
all-features = true
-features = ["alloc", "std", "docsrs"]
+
[profile.bench]
lto = true
codegen-units = 1
debug = true
[[example]]
+name = "custom_error"
+path = "examples/custom_error.rs"
+required-features = ["alloc"]
+
+[[example]]
name = "json"
path = "examples/json.rs"
required-features = ["alloc"]
[[example]]
+name = "json_iterator"
+path = "examples/json_iterator.rs"
+required-features = ["alloc"]
+
+[[example]]
name = "iterator"
path = "examples/iterator.rs"
@@ -98,6 +131,7 @@ name = "reborrow_fold"
[[test]]
name = "fnmut"
required-features = ["alloc"]
+
[dependencies.memchr]
version = "2.3"
default-features = false
@@ -105,21 +139,25 @@ default-features = false
[dependencies.minimal-lexical]
version = "0.2.0"
default-features = false
+
[dev-dependencies.doc-comment]
version = "0.3"
[dev-dependencies.proptest]
version = "1.0.0"
-[build-dependencies.version_check]
-version = "0.9"
[features]
alloc = []
default = ["std"]
docsrs = []
-std = ["alloc", "memchr/std", "minimal-lexical/std"]
+std = [
+ "alloc",
+ "memchr/std",
+ "minimal-lexical/std",
+]
+
[badges.coveralls]
-branch = "master"
+branch = "main"
repository = "Geal/nom"
service = "github"