summaryrefslogtreecommitdiffstats
path: root/vendor/num-integer/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/num-integer/README.md
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/num-integer/README.md')
-rw-r--r--vendor/num-integer/README.md50
1 files changed, 0 insertions, 50 deletions
diff --git a/vendor/num-integer/README.md b/vendor/num-integer/README.md
deleted file mode 100644
index 249d5f046..000000000
--- a/vendor/num-integer/README.md
+++ /dev/null
@@ -1,50 +0,0 @@
-# num-integer
-
-[![crate](https://img.shields.io/crates/v/num-integer.svg)](https://crates.io/crates/num-integer)
-[![documentation](https://docs.rs/num-integer/badge.svg)](https://docs.rs/num-integer)
-[![minimum rustc 1.8](https://img.shields.io/badge/rustc-1.8+-red.svg)](https://rust-lang.github.io/rfcs/2495-min-rust-version.html)
-[![build status](https://github.com/rust-num/num-integer/workflows/master/badge.svg)](https://github.com/rust-num/num-integer/actions)
-
-`Integer` trait and functions for Rust.
-
-## Usage
-
-Add this to your `Cargo.toml`:
-
-```toml
-[dependencies]
-num-integer = "0.1"
-```
-
-and this to your crate root:
-
-```rust
-extern crate num_integer;
-```
-
-## Features
-
-This crate can be used without the standard library (`#![no_std]`) by disabling
-the default `std` feature. Use this in `Cargo.toml`:
-
-```toml
-[dependencies.num-integer]
-version = "0.1.36"
-default-features = false
-```
-
-There is no functional difference with and without `std` at this time, but
-there may be in the future.
-
-Implementations for `i128` and `u128` are only available with Rust 1.26 and
-later. The build script automatically detects this, but you can make it
-mandatory by enabling the `i128` crate feature.
-
-
-## Releases
-
-Release notes are available in [RELEASES.md](RELEASES.md).
-
-## Compatibility
-
-The `num-integer` crate is tested for rustc 1.8 and greater.