summaryrefslogtreecommitdiffstats
path: root/vendor/object/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /vendor/object/Cargo.toml
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/object/Cargo.toml')
-rw-r--r--vendor/object/Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/vendor/object/Cargo.toml b/vendor/object/Cargo.toml
index a94180ee1..0d90ab271 100644
--- a/vendor/object/Cargo.toml
+++ b/vendor/object/Cargo.toml
@@ -12,12 +12,13 @@
[package]
edition = "2018"
name = "object"
-version = "0.29.0"
+version = "0.30.1"
exclude = [
"/.github",
"/testfiles",
]
description = "A unified interface for reading and writing object file formats."
+readme = "README.md"
keywords = [
"object",
"elf",
@@ -27,6 +28,7 @@ keywords = [
]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/gimli-rs/object"
+resolver = "2"
[package.metadata.docs.rs]
features = ["doc"]
@@ -55,7 +57,7 @@ version = "1"
optional = true
[dependencies.hashbrown]
-version = "0.12.0"
+version = "0.13.1"
features = ["ahash"]
optional = true
default-features = false
@@ -124,6 +126,12 @@ rustc-dep-of-std = [
]
std = ["memchr/std"]
unaligned = []
+unstable = []
+unstable-all = [
+ "all",
+ "unstable",
+ "xcoff",
+]
wasm = ["wasmparser"]
write = [
"write_std",
@@ -143,3 +151,4 @@ write_std = [
"indexmap/std",
"crc32fast/std",
]
+xcoff = []