summaryrefslogtreecommitdiffstats
path: root/vendor/object/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/object/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/object/Cargo.toml')
-rw-r--r--vendor/object/Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/vendor/object/Cargo.toml b/vendor/object/Cargo.toml
index 84efba254..4ea28afcc 100644
--- a/vendor/object/Cargo.toml
+++ b/vendor/object/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "object"
-version = "0.30.2"
+version = "0.31.1"
exclude = [
"/.github",
"/testfiles",
@@ -70,8 +70,12 @@ optional = true
version = "2.4.1"
default-features = false
+[dependencies.ruzstd]
+version = "0.3.1"
+optional = true
+
[dependencies.wasmparser]
-version = "0.57"
+version = "0.102.0"
optional = true
[features]
@@ -87,6 +91,7 @@ cargo-all = []
coff = []
compression = [
"flate2",
+ "ruzstd",
"std",
]
default = [
@@ -104,6 +109,7 @@ doc = [
"macho",
"pe",
"wasm",
+ "xcoff",
]
elf = []
macho = []
@@ -115,6 +121,7 @@ read = [
"elf",
"macho",
"pe",
+ "xcoff",
"unaligned",
]
read_core = []
@@ -130,7 +137,6 @@ unstable = []
unstable-all = [
"all",
"unstable",
- "xcoff",
]
wasm = ["wasmparser"]
write = [
@@ -139,6 +145,7 @@ write = [
"elf",
"macho",
"pe",
+ "xcoff",
]
write_core = [
"crc32fast",