summaryrefslogtreecommitdiffstats
path: root/vendor/orion/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/orion/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/orion/Cargo.toml')
-rw-r--r--vendor/orion/Cargo.toml105
1 files changed, 105 insertions, 0 deletions
diff --git a/vendor/orion/Cargo.toml b/vendor/orion/Cargo.toml
new file mode 100644
index 000000000..aa0e34bde
--- /dev/null
+++ b/vendor/orion/Cargo.toml
@@ -0,0 +1,105 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "orion"
+version = "0.17.3"
+authors = ["brycx <brycx@protonmail.com>"]
+exclude = [
+ ".gitignore",
+ ".travis.yml",
+ "tests/*",
+]
+description = "Usable, easy and safe pure-Rust crypto"
+documentation = "https://docs.rs/orion"
+readme = "README.md"
+keywords = [
+ "cryptography",
+ "crypto",
+ "aead",
+ "hash",
+ "mac",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/orion-rs/orion"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[profile.dev]
+opt-level = 1
+
+[[bench]]
+name = "bench"
+harness = false
+
+[dependencies.ct-codecs]
+version = "1.1.1"
+optional = true
+
+[dependencies.fiat-crypto]
+version = "0.1.11"
+default-features = false
+
+[dependencies.getrandom]
+version = "0.2.0"
+optional = true
+
+[dependencies.serde]
+version = "1.0.124"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.subtle]
+version = "^2.2.2"
+default-features = false
+
+[dependencies.zeroize]
+version = "1.1.0"
+default-features = false
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+
+[dev-dependencies.hex]
+version = "0.4.0"
+
+[dev-dependencies.quickcheck]
+version = "1"
+
+[dev-dependencies.quickcheck_macros]
+version = "1"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0.41"
+
+[features]
+alloc = []
+default = ["safe_api"]
+safe_api = [
+ "getrandom",
+ "ct-codecs",
+]