summaryrefslogtreecommitdiffstats
path: root/vendor/os_str_bytes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/os_str_bytes/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/os_str_bytes/Cargo.toml')
-rw-r--r--vendor/os_str_bytes/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/vendor/os_str_bytes/Cargo.toml b/vendor/os_str_bytes/Cargo.toml
new file mode 100644
index 000000000..8124213a0
--- /dev/null
+++ b/vendor/os_str_bytes/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.52.0"
+name = "os_str_bytes"
+version = "6.0.0"
+authors = ["dylni"]
+exclude = [".*", "/rustfmt.toml", "/tests"]
+description = "Utilities for converting between byte sequences and platform-native strings\n"
+readme = "README.md"
+keywords = ["bytes", "osstr", "osstring", "path", "windows"]
+categories = ["command-line-interface", "development-tools::ffi", "encoding", "os", "rust-patterns"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dylni/os_str_bytes"
+[package.metadata.docs.rs]
+all-features = true
+rustc-args = ["--cfg", "os_str_bytes_docs_rs"]
+rustdoc-args = ["--cfg", "os_str_bytes_docs_rs"]
+[dependencies.memchr]
+version = "2.4"
+optional = true
+
+[dependencies.print_bytes]
+version = "0.5"
+optional = true
+
+[dependencies.uniquote]
+version = "3.0"
+optional = true
+[dev-dependencies.getrandom]
+version = "0.2"
+
+[features]
+default = ["memchr", "raw_os_str"]
+raw_os_str = []