summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot_core-0.8.5/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:50 +0000
commit2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35 (patch)
treed325add32978dbdc1db975a438b3a77d571b1ab8 /vendor/parking_lot_core-0.8.5/Cargo.toml
parentReleasing progress-linux version 1.68.2+dfsg1-1~progress7.99u1. (diff)
downloadrustc-2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35.tar.xz
rustc-2e00214b3efbdfeefaa0fe9e8b8fd519de7adc35.zip
Merging upstream version 1.69.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/parking_lot_core-0.8.5/Cargo.toml')
-rw-r--r--vendor/parking_lot_core-0.8.5/Cargo.toml52
1 files changed, 0 insertions, 52 deletions
diff --git a/vendor/parking_lot_core-0.8.5/Cargo.toml b/vendor/parking_lot_core-0.8.5/Cargo.toml
deleted file mode 100644
index 7afeb4114..000000000
--- a/vendor/parking_lot_core-0.8.5/Cargo.toml
+++ /dev/null
@@ -1,52 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "parking_lot_core"
-version = "0.8.5"
-authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
-description = "An advanced API for creating custom synchronization primitives."
-keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
-categories = ["concurrency"]
-license = "Apache-2.0/MIT"
-repository = "https://github.com/Amanieu/parking_lot"
-[dependencies.backtrace]
-version = "0.3.60"
-optional = true
-
-[dependencies.cfg-if]
-version = "1.0.0"
-
-[dependencies.instant]
-version = "0.1.9"
-
-[dependencies.petgraph]
-version = "0.5.1"
-optional = true
-
-[dependencies.smallvec]
-version = "1.6.1"
-
-[dependencies.thread-id]
-version = "4.0.0"
-optional = true
-
-[features]
-deadlock_detection = ["petgraph", "thread-id", "backtrace"]
-nightly = []
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.8"
-[target."cfg(unix)".dependencies.libc]
-version = "0.2.95"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]