summaryrefslogtreecommitdiffstats
path: root/vendor/partial_ref_derive
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/partial_ref_derive
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/partial_ref_derive')
-rw-r--r--vendor/partial_ref_derive/.cargo-checksum.json1
-rw-r--r--vendor/partial_ref_derive/Cargo.toml32
-rw-r--r--vendor/partial_ref_derive/LICENSE-APACHE201
-rw-r--r--vendor/partial_ref_derive/LICENSE-MIT25
-rw-r--r--vendor/partial_ref_derive/README.md23
-rw-r--r--vendor/partial_ref_derive/src/lib.rs287
6 files changed, 569 insertions, 0 deletions
diff --git a/vendor/partial_ref_derive/.cargo-checksum.json b/vendor/partial_ref_derive/.cargo-checksum.json
new file mode 100644
index 000000000..200baeca1
--- /dev/null
+++ b/vendor/partial_ref_derive/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"a17795308b5feb72b1b93dd6589bf0d75db791c642b6b024c189723cc3b28ec6","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"518718c95bcadbc4796051b0dfe05500fddc5b21cb68dab51857ca85f3fd438d","README.md":"e760cf6313db6154c91878a2c8f69006addc889b5aed6d949a7df3681ebe584e","src/lib.rs":"03253440856eaa11d655351e21bbb22e399f8978a3d82e9dc9d6be5e5a74de7c"},"package":"300e1d2cb5b898b5a5342e994e0d0c367dbfe69cbf717cd307045ec9fb057581"} \ No newline at end of file
diff --git a/vendor/partial_ref_derive/Cargo.toml b/vendor/partial_ref_derive/Cargo.toml
new file mode 100644
index 000000000..2794ad37f
--- /dev/null
+++ b/vendor/partial_ref_derive/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "partial_ref_derive"
+version = "0.3.3"
+authors = ["Jannis Harder <me@jix.one>"]
+description = "Derives for partial_ref"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jix/partial_ref"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro2]
+version = "1.0.20"
+
+[dependencies.quote]
+version = "1.0.7"
+
+[dependencies.syn]
+version = "1.0.40"
diff --git a/vendor/partial_ref_derive/LICENSE-APACHE b/vendor/partial_ref_derive/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/partial_ref_derive/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/partial_ref_derive/LICENSE-MIT b/vendor/partial_ref_derive/LICENSE-MIT
new file mode 100644
index 000000000..90f71a8d7
--- /dev/null
+++ b/vendor/partial_ref_derive/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018 Jannis Harder
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/partial_ref_derive/README.md b/vendor/partial_ref_derive/README.md
new file mode 100644
index 000000000..985193780
--- /dev/null
+++ b/vendor/partial_ref_derive/README.md
@@ -0,0 +1,23 @@
+# partial_ref_derive - Derives for partial_ref
+
+This crate provides derives for the [partial_ref] crate.
+
+## License
+
+The partial_ref source code is licensed under either of
+
+ * Apache License, Version 2.0
+ ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license
+ ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in partial_ref by you, as defined in the Apache-2.0 license,
+shall be dual licensed as above, without any additional terms or conditions.
+
+[partial_ref]:https://crates.io/crates/partial_ref
diff --git a/vendor/partial_ref_derive/src/lib.rs b/vendor/partial_ref_derive/src/lib.rs
new file mode 100644
index 000000000..f204fd84a
--- /dev/null
+++ b/vendor/partial_ref_derive/src/lib.rs
@@ -0,0 +1,287 @@
+//! Derives instances of PartialRefTarget and associated traits for the `partial_ref` crate.
+#![recursion_limit = "128"]
+extern crate proc_macro;
+
+use std::collections::HashSet;
+
+use crate::proc_macro::TokenStream;
+
+use proc_macro2::{Span, TokenTree};
+use quote::{quote, ToTokens};
+use syn::{
+ parse_macro_input, parse_quote, parse_str, Attribute, Data, DeriveInput, Lifetime, LifetimeDef,
+ Lit, Member, Meta, Type, TypeParen,
+};
+
+fn parse_attribute_as_type(attr: &Attribute) -> Type {
+ if let Some(TokenTree::Group(group)) = attr.tokens.clone().into_iter().next() {
+ let parsed_type: Type = parse_quote!(#group);
+ // This avoids unnecessary parentheses around type warnings from the generated code.
+ if let Type::Paren(TypeParen { elem, .. }) = parsed_type {
+ return *elem;
+ }
+ return parsed_type;
+ }
+
+ let parse_panic = || panic!("could not parse attribute `{}`", attr.tokens.to_string());
+ let meta = attr.parse_meta().unwrap_or_else(|_| parse_panic());
+ if let Meta::NameValue(name_value) = meta {
+ if let Lit::Str(string) = name_value.lit {
+ match parse_str(&string.value()) {
+ Err(_) => panic!("could not parse type `{}` in attribute", string.value()),
+ Ok(parsed_type) => return parsed_type,
+ }
+ }
+ }
+ parse_panic();
+ unreachable!()
+}
+
+/// If the input is non-empty remove the enclosing `<` and `>` and prepend a comma.
+///
+/// Does not check whether the enclosing tokens actually are `<` and `>`.
+fn generics_to_extra_generics(generics: &impl ToTokens) -> proc_macro2::TokenStream {
+ let mut generics_tokens = proc_macro2::TokenStream::new();
+ generics.to_tokens(&mut generics_tokens);
+
+ let mut generics_tokens = generics_tokens.into_iter().collect::<Vec<_>>();
+
+ if !generics_tokens.is_empty() {
+ generics_tokens[0] = quote!(,).into_iter().next().unwrap();
+ generics_tokens.pop();
+ }
+
+ let mut extra_tokens = proc_macro2::TokenStream::new();
+ extra_tokens.extend(generics_tokens);
+ extra_tokens
+}
+
+/// Generate a new lifetime that doesn't conflict with the existing lifetimes.
+fn fresh_lifetime<'a>(lifetimes: impl Iterator<Item = &'a LifetimeDef>, name: &str) -> Lifetime {
+ let mut used_idents = HashSet::new();
+ for lifetime in lifetimes {
+ used_idents.insert(lifetime.lifetime.ident.to_string());
+ }
+
+ let mut lifetime_name = name.to_owned();
+ let mut counter = 0;
+
+ while used_idents.contains(&lifetime_name) {
+ use std::fmt::Write;
+ counter += 1;
+ lifetime_name.clear();
+ write!(&mut lifetime_name, "{}{}", name, counter).unwrap();
+ }
+
+ Lifetime::new(&format!("'{}", lifetime_name), Span::call_site())
+}
+
+/// Derives instances of PartialRefTarget and associated traits.
+///
+/// Can only be used for structs. The attribute `#[part(PartName)]` can be used on the struct itself
+/// for an abstract part or on a field for a field part. Parts have to be declared separately.
+/// `PartName` can be any valid rust type that implements the Part trait. For fields the field type
+/// of the part has to match the actual type of the field.
+///
+/// Example:
+///
+/// ```ignore
+/// use partial_ref::{PartialRefTarget, part};
+///
+/// #[derive(PartialRefTarget)]
+/// #[part(SomeAbstractPart)]
+/// struct ExampleStruct {
+/// field_without_part: usize,
+/// #[part(SomeFieldPart)]
+/// a: usize,
+/// #[part(another_crate::AnotherFieldPart)]
+/// b: usize,
+/// }
+/// ```
+///
+/// Instead of `#[part(PartName)]` it is also possible to use `#[part = "PartName"]` which was the
+/// only supported syntax in previous versions of this crate.
+///
+
+// TODO figure out how to link to doc items of the partial_ref crate
+#[proc_macro_derive(PartialRefTarget, attributes(part))]
+pub fn derive_partial_ref_target(input: TokenStream) -> TokenStream {
+ let input = parse_macro_input!(input as DeriveInput);
+
+ let target_ident = input.ident;
+
+ let lt_a = fresh_lifetime(input.generics.lifetimes(), "a");
+
+ let (impl_generics, target_generics, where_clause) = input.generics.split_for_impl();
+
+ if where_clause.is_some() {
+ panic!("cannot derive PartialRef target for structs with a where clause");
+ // TODO lift this restriction
+ }
+
+ let extra_generics = generics_to_extra_generics(&impl_generics);
+
+ let target_type = quote!(#target_ident #target_generics);
+
+ let data_struct = match input.data {
+ Data::Struct(data_struct) => data_struct,
+ _ => panic!("deriving PartialRefTarget is only supported on structs"),
+ };
+
+ let mut abstract_parts: Vec<Type> = vec![];
+ let mut typed_parts: Vec<(Member, Type)> = vec![];
+
+ for attr in input.attrs.iter() {
+ if attr.path.is_ident("part") {
+ abstract_parts.push(parse_attribute_as_type(&attr));
+ }
+ }
+
+ for (field_index, field) in data_struct.fields.iter().enumerate() {
+ let mut part: Option<Type> = None;
+
+ for attr in field.attrs.iter() {
+ if attr.path.is_ident("part") {
+ if part.is_some() {
+ panic!(
+ "{} has multiple parts",
+ field
+ .ident
+ .as_ref()
+ .map_or("unnamed field".to_owned(), |i| format!("field `{}`", i))
+ );
+ }
+ part = Some(parse_attribute_as_type(&attr));
+ }
+ }
+
+ if let Some(part_type) = part {
+ let member = field
+ .ident
+ .as_ref()
+ .map_or(Member::Unnamed(field_index.into()), |ident| {
+ Member::Named(ident.clone())
+ });
+ typed_parts.push((member, part_type));
+ }
+ }
+
+ let mut const_type = quote!(::partial_ref::Ref<#lt_a, #target_type>);
+ let mut mut_type = quote!(::partial_ref::Ref<#lt_a, #target_type>);
+ let mut split_const_type = quote!(Reference);
+ let mut split_mut_type = quote!(Reference);
+
+ for part in abstract_parts.iter() {
+ const_type = quote!(::partial_ref::Const<#part, #const_type>);
+ mut_type = quote!(::partial_ref::Mut<#part, #mut_type>);
+
+ split_const_type = quote!(
+ ::partial_ref::Const<
+ ::partial_ref::Nested<ContainingPart, #part>,
+ #split_const_type
+ >
+ );
+ split_mut_type = quote!(
+ ::partial_ref::Mut<
+ ::partial_ref::Nested<ContainingPart, #part>,
+ #split_mut_type
+ >
+ );
+ }
+
+ for (_, part) in typed_parts.iter() {
+ const_type = quote!(::partial_ref::Const<#part, #const_type>);
+ mut_type = quote!(::partial_ref::Mut<#part, #mut_type>);
+
+ split_const_type = quote!(
+ ::partial_ref::Const<
+ ::partial_ref::Nested<ContainingPart, #part>,
+ #split_const_type
+ >
+ );
+ split_mut_type = quote!(
+ ::partial_ref::Mut<
+ ::partial_ref::Nested<ContainingPart, #part>,
+ #split_mut_type
+ >
+ );
+ }
+
+ let mut result = vec![];
+
+ result.push(TokenStream::from(quote! {
+ impl<#lt_a #extra_generics> ::partial_ref::IntoPartialRef<#lt_a> for &#lt_a #target_type {
+ type Ref = #const_type;
+ #[inline(always)]
+ fn into_partial_ref(self) -> Self::Ref {
+ unsafe {
+ <Self::Ref as ::partial_ref::PartialRef>::from_raw(self as *const _ as *mut _)
+ }
+ }
+ }
+
+ impl<#lt_a #extra_generics> ::partial_ref::IntoPartialRef<#lt_a>
+ for &#lt_a mut #target_type {
+ type Ref = #mut_type;
+ #[inline(always)]
+ fn into_partial_ref(self) -> Self::Ref {
+ unsafe {
+ <Self::Ref as ::partial_ref::PartialRef>::from_raw(self as *mut _)
+ }
+ }
+ }
+
+ unsafe impl<#lt_a #extra_generics, ContainingPart, Reference>
+ ::partial_ref::SplitIntoParts<#lt_a, ContainingPart, Reference> for #target_type
+ where
+ ContainingPart: ::partial_ref::Part<PartType=::partial_ref::Field<Self>>,
+ Reference: ::partial_ref::PartialRef<#lt_a>,
+ Reference::Target: ::partial_ref::HasPart<ContainingPart>,
+ {
+ type Result = #split_const_type;
+ type ResultMut = #split_mut_type;
+ }
+
+ impl #impl_generics ::partial_ref::PartialRefTarget for #target_type {
+ type RawTarget = Self;
+ }
+ }));
+
+ for part in abstract_parts.iter() {
+ result.push(TokenStream::from(quote! {
+ impl #impl_generics ::partial_ref::HasPart<#part> for #target_type {
+ #[inline(always)]
+ unsafe fn part_ptr(ptr: *const Self) -> () {
+ unreachable!()
+ }
+
+ #[inline(always)]
+ unsafe fn part_ptr_mut(ptr: *mut Self) -> () {
+ unreachable!()
+ }
+ }
+ }));
+ }
+
+ for (member, part) in typed_parts.iter() {
+ result.push(TokenStream::from(quote! {
+ impl #impl_generics ::partial_ref::HasPart<#part> for #target_type {
+ #[inline(always)]
+ unsafe fn part_ptr(
+ ptr: *const Self
+ ) -> <<#part as ::partial_ref::Part>::PartType as ::partial_ref::PartType>::Ptr {
+ ::core::ptr::addr_of!((*ptr).#member)
+ }
+
+ #[inline(always)]
+ unsafe fn part_ptr_mut(
+ ptr: *mut Self
+ ) -> <<#part as ::partial_ref::Part>::PartType as ::partial_ref::PartType>::PtrMut {
+ ::core::ptr::addr_of_mut!((*ptr).#member)
+ }
+ }
+ }));
+ }
+
+ result.into_iter().collect()
+}